Tasmota PCF8574 input doesn't work

good day
I have inputs/outputs solved with the help of ESP-01 Tasmot and expander PCF8574. Outputs are responsive with Tasmota integration. Inputs are not. I tried writing the inputs using *.yaml. They still don’t respond. Tasmoty console and MQTT explorer show that it should work:
Example: stat/TasmotaX112/RESULT = {“Time”:“2023-01-07T18:44:43”,“PCF8574-1_INP”:{“D1”:0}}
notation in *.yaml:

   - name: X112_IN_00
     #  state_topic: "stat/TasmotaX112/RESULT"
      # value_template: "{{ value_json.PCF8574-1_INP.D0 }}" # TemplateSyntaxError: expected token 
      # end of print statement, got _INP
     state_topic: "stat/TasmotaX112/RESULT/PCF8574-1_INP"
     value_template: "{{value_json.D1 }}"
     availability_topic: tele/TasmotaX112/LWT
     payload_available: Online
     payload_not_available: Offline

I tried other notations. I guess PCF8574-1_INP → _INP bothers him ???

Thank you for your help

Did you manage to solve your problem in the meantime?
Because right now I’m facing the same problem.

Greetings, -chris-

Meanwhile I found a solution.
I use ESPHome. Very nice integration.
And the i2c control over a wemos d1 with three 8 port i/o boards is really easy to do and works as expected.

1 Like