Tasmota RGBW bulb with Google Assistant (via Nabu Casa) - no white!

Tags: #<Tag:0x00007f73ae20f610> #<Tag:0x00007f73ae20f2a0>

Hi all,

I’ve been gradually migrating all of my Tuya devices over to Tasmota, with the intention of using them in conjunction with Home Assistant Cloud to make my house less dependent on third-party services (i.e. SmartLife!). So far, it’s been a huge success and I remain in awe of the quality of both Home Assistant and Tasmota to make a really robust platform.

I’ve hit one slightly annoying bug though, which I can’t figure out and I’m hoping someone here can help.

I have a few bulbs that are RGBW (i.e. RGB + cold white) that, after a bit of mucking about, are correctly mapped in HA. I can open the entity and set the colour and also, more importantly, control the white channel. So when asking for red from the HA UI, the Tasmota console correctly reports that the right RGBW value is being requested:

11:30:51 MQT: stat/kitchentablelamp/RESULT = {"POWER":"ON","Dimmer":100,"Color":"255,0,0,0","HSBColor":"0,100,100","White":0,"Channel":[100,0,0,0]}

…and when asking for white, it correctly turns off the RGB channels and just enables the W channel at 100%:

11:32:40 MQT: stat/kitchentablelamp/RESULT = {"POWER":"ON","Dimmer":100,"Color":"0,0,0,255","HSBColor":"0,0,0","White":100,"Channel":[0,0,0,100]}

These colours are also correctly displayed on the lamp.

The problem I have is that when I ask Google Assistant to “set lamp to white”, as I would previously have done with SmartLife, it only triggers a regular RGB value to be configured on the bulb. e.g.

11:37:36 MQT: stat/kitchentablelamp/RESULT = {"POWER":"ON","Dimmer":100,"Color":"255,221,172,0","HSBColor":"35,33,100","White":0,"Channel":[100,87,67,0]}

This results in a rather dim, muddy colour on the bulb rather than the normal, bright-white that the bulb should put out. This also happens if you ask for “bright white” (which sets the RBG to #FFFFFF, but still doesn’t set the white channel).

It looks like the HA / GA integration isn’t correctly advertising the capability of the bulb to Google, but I’m somewhat stumped as to how to fix this.

Suggestions welcomed!

1 Like

Replying to myself, because seeing other odd behaviours with different lights too.

In this case, a RGBCCT light (i.e. RGB + tunable white). The light works perfectly from the UI and I can create a scene with it, tuning the light temperature in the scene to what I want (and the bulb mirrors the setting perfectly while creating the scene - I can see the white settings being applied in Tasmota). I then save the scene, and execute it…and the bulb colour is set as though the bulb was only RGB - so in my case, a nicely tuned warm white becomes a slightly nasty purpley colour when the scene is applied.

There’s definitely something odd going on here…