Tasmota sensors update interval

Hi everyone,

I have a couple of Athom Tech Power Monitoring Plug (these ones → https://it.athom.tech/blank-1/color-smart-plug) which are running Tasmota firmware by default and are awesome.

I am using the native HA Tasmota integration and I am using the custom mini-graph card to display total energy usage, real-time energy usage and so on.

I noticed that the real-time energy usage isn’t getting reported back to HA in real-time, but instead with a delay of a couple of minutes or so.

This is happening with the custom mini-graph card as well with the native sensor card, so it is not a limitation of the custom card I am using.

I read that this could be a limit of Tasmota firmware, since by default the Teleperiod is set to 300 seconds. I read that this could be lowered to a minimum of 10 seconds, which should improve my real-time reading but it is still not “real real-time”.

I was wondering what can I do to have a real-time reading/report from the sensors (for example, every 1 or 2 seconds).

EDIT: if I visit the web ui of the Plug (i.e. 192.168.1.xxx) I can see that all the sensors readings are updating immediately and are reporting the real time values)

Thank you for the help

Also tried to set up a rule and a timer as explained in this video at the 24min mark

But I still cannot see the real time readings in HA.

Anyone has a solution to this?

What is the update_interval on the mini graph card ?

1 Like

Hi @francisp, I managed to solve this issue by deleting the rule+timer and using the PowerDelta command and set it to the lowest value possible (which is 1).

By doing so, I am getting real-time sensors reading every time one value changes by at least 1%.

With this configuration in place, I am getting real-time sensor readings (like every 1 or 2 seconds) for appliances which are always up and running (like a fridge, for example). And I am getting sensor readings every time a value changes for at least 1%, which is great also for appliances which are getting used from time to time (like a microwave, for example).

For this appliances this configuration also eliminate the constant spamming to the MQTT broker that I had before, since with rule + timer I always got a report even when nothing was changing.

I did not specify the update_interveal setting because I read that if it is not specified the graph should update as soon as a change in value is registered


I’m just getting into rules. Can you please post your rule statement?

Hi @johnny2265, for what is worth I am not using any rules on these power monitoring plugs at the moment.

I just applied from the Tasmota console the following commands:

PowerOnState 1 → This means that the default power setting of the plug is “ON” (it is useful when the power goes out and comes back, all the devices attached to this smart plug will get power asap).

PowerDelta 1 → This is the setting I use to get real-time reading of Energy/Power consumption as well as Voltages. PowerDelta 1 means that whenever there’s a difference of at least 1% from the previous reading that value is posted via MQTT to HA (useful if you want real-time updates on your reading or your graphs)

Optionally if you find that the voltage readings are a bit off you could do a calibration with a fixed power source (for example an old incandescent bulb) and dial in the correct value using the command VoltageSet (Power Monitoring Calibration - Tasmota).


From here:

1 Like

Based on @123’s suggestion, I set PowerDelta to 101 and now I get immediate updates whenever the power changes by 1W or more.

Now I know this is a pretty old topic, but i’ll still try.

I just bought a couple of Athom Power Plugs, they identify as Athom Plug v3. I’ve read the update interval for power metering is by default set to 300 seconds. Which seems pretty high. In practice it doens’t fit my needs. When power consumption rises i want to shut down the sonos systems. And now there is a huge delay.

I was looking into this, but can’t seem to find a way to alter these configs. Any points on how to change this?