Tasmota Smart Plug no longer controllable (missing `switch` entity)

I am using Tasmota switches via the MQTT Mosquitto addon and everything worked fine until my HASS rebooted and they were all missing - I assume I faced Tasmota Integration: Unavailable Devices After Reboot - #35 by Mastiff and followed the instructions in the 2nd to last post. After clearing the MQTT topic and rebooting the devices, they came back (though all lost their settings and names), but they no longer have an on/off switch in HA. In the web interface I can switch on/off just fine. Power consumption and so on is displayed in HA correctly, it’s really just the missing switch entity that is the problem.

The device itself has not been reconfigured since it worked, so the Tasmota template and so on are configured correctly.

1 Like

Oh, and SetOption19 was already at 0 for all my devices

I gave up on those things. Shelly plugs are both cheaper and a LOT easier to interface. I use the Tasmotas only with some Node-RED stuff now, where I control them directly with MQTT.