Tasmota Switch not showing up

Tags: #<Tag:0x00007f739ab67b90> #<Tag:0x00007f739ab67ac8> #<Tag:0x00007f739ab67a00>

Good Morning,
I’ve got a question regarding Tasmota (Option 19 Autodiscovery: On) and Autodiscovery with Home Assistant. My Tasmota is latest Release 8.2.0 from March. Home-Assistant is 0.108.3. The Device is a ESP-01 with Binary Switch (ON/OFF) on GPIO0, configured as “Switch 1(9)”. There is another Temperature Sensor, DS18b20, on GPIO2.

On Home-Assistant side MQTT Connection is configured and running. There are several other Sensors configured on fixed topics. Autodiscovery is enabled. Enabling Autodiscovery Option 19 on Tasmota immadiately shows the device in lovelace. There are two Bullets showing up: In one hand there is the Status Button, that contains RSSI, Built, IP-Address, etc. In other hand there is the Temperature Sensor DS18b20, that shows current temp in lovelace. But the binary switch is not showing up, whatever i try to get it running.

Watching the Console on Tasmota i can see the Pin changes and sending it to telemetry topic. Can anyone help me on that?

Best,
redflag237

Can show your mqtt config section

also can you also show the tasmota console ( screen shot)

I think your GPIO0 needs to be defined as Relay1, not Switch1

@francisp No, Relais is defining an Output, Switch is an Binary Input.

It found out, how to get it running. Strange thing - feels like a bug! On the Tasmota MQTT Settings Page, there is a field “Topic”, with a default value. I changed this value to custom and immadiately after that change the Switch Entity appeared.

It’s not a bug. It is something you always must do. All your tasmotas need a unique topic defined there.

I double-checked the default topic, it was already unique. I assume it was a bug, since partially things appeared, except the binary switch.