Tasmota Upgrade

I recently upgrade a device from Tasmota 8.3 to 9.5. Once the upgrade was finished, this is the error message I received:


I don’t see the regular menu. So then I tried to manually upload the .bin file and this is the error message I got:


Do I need to re-flash the switch or is there something I can do from the console?

Thanks in advance for any help that can be provided.

Which .bin file are you uploading?

Not sure if this has anything to do with this specific “Not enough space” issue, but keep in mind that you need to follow the recommended upgrade path as outlined here:

It was the 9.5 bin file. What I’ve tried is switching back to 8.5.1 which seems to have worked. In 9.5 the MQTT integration / communication seems to be broken.


Thanks exxamalte for the firmware upgrade process. I definitively didn’t follow these steps and that maybe my issue.

1 Like

The traditional way that Tasmota has worked with Home Assistant is via Home Assistant’s MQTT Discovery. Tasmota has deprecated this method in favor of their own technique which requires the use of the Tasmota integration in Home Assistant. In the future, they will eliminate support for MQTT Discovery entirely.