TC2S-1 Gang switch with RM2 Pro Plus3

Hi, I need help with getting the RF code for my TC2S switch by bestcon. Tried using the broadlink app and the switch works but it paired by scanning qr code so im not sure what to do to get the rf code. I tried the normal way as well, put it in scanning mode and press the switch button but it dosent work as well. need help thanks

anyone pls help

Following the same! Am facing same issue and tried using broadlink manager. I even use a spare rm pro to scan + broadlink manager (the same method works for tc2 switches and almost everything).

the tc2s switch is working properly when connected to broadlink cloud

anyone got solution can help

has the same issue here! it would be great if I can know the rf code. I try to use sonoff rf bridge, but still can’t learn the broadlink rf code

I am also having similar issue. Now am stuck with the switch that can’t be integrated to my home assistant. Hope anyone got way to capture the rf codes with this switch.

I did a lot of work on this with no success for TC2’s. Here is what I’ve done, maybe you are more lucky than me: Broadlink RM-PRO and TC2 switch