TCP commands for Ethernet relay

Yeah, no hurry, maybe you can create some example script that I can run, to see if it generates correct output…
So I don’t have to install the whole custom component

dimming is working, one issue left: the icon doesn’t immediately change when I update the dimmed lights brightness or when I switch it on/off:

It does update after I’ve polled the Dobiss state. The normal light icons do update immediately as expected.

yeah, i have that too with my dimmers they update indeed after the poll
i solved that in my light switch… whenever i turn on a light (command) , i also change the state with a rest command, so for every light/switch i have 2 commands, one for the actual light and for the state
so my state is immediately changed , looks much nicer

yes I’ve used the REST command as well, but it doesn’t update the icon for the dimmed lamps… And I don’t get an error or something

what if you just do the only rest command as a test? just to see if it works?

hey @pergola.fabio thank you so much for your help. I made a typo in my command. Everything is up and running now. I’ve created a new post with my whole setup: Dobiss lights integration

yeah, i saw it! indeed its better to create a new topic for new dobiss guys

maybe also mention that @spobo is creating a new component, so all this config is not needed anymore soon :slight_smile:

also maybe mention those 2 pdf files i shared , to make this project, i received them from dobiss

I used the dobiss specific thread to post an update to dobiss2mqtt. If it really works I’ll probably create a new thread for it. So check: Dobiss lights integration


I’m new to Home Assistant and trying to find my way around.
I’m used to Domoticz but wanted to try something new so the logical choice was HA.

I created my own standalone home automation system that is based on a RS485 bus system with my own protocol (just 7 bytes) and has an Ethernet interface that accepts raw TCP packets.
I used Domoticz as an add-on to do some additional automation.
In Domoticz I used to run a Python script that sends the necessary bytes over to my system.

I’m looking to do the same from HA but can’t seem to get it going.
I’ve been reading and trying all kind of posts but still no joy.

The idea is basically the same as the one from Fabio but when running the python script I get an error that the import socket is not working. I read that python is kind of ‘sandboxed’ in HA.

Next to that I tried the curl option like:
echo -e “\xFE\xF5\xCA\x06\x03\x00\x3A” | nc 1500
Also did get it going.

I’m also a bit stuck in where to run what. What is the best way to test the curl command and same for the python script.
Tips and tricks are very welcome.

Thank you


you dont need an python script, you can just fire that with a command line switch/script

Thank you for the swift reply !

I also tried this before but think that my syntax might be wrong.
Could you please check if the given example is correct?

Example configuration.yaml entry


  • platform: command_line
    command_on: echo -e “\xFE\xF5\xCA\x06\x03\x00\x3A” | nc 1500
    command_off: echo -e “\xFE\xF5\xCA\x06\x02\x00\x3A” | nc 1500

i think you need some extra quotes for your command

Could you tell me how you got the python script working as the curl or shell is not working for me unfortunately?
Then I can give it a try with the python script I used to work with.

Thank you

look at my post earlier, some examples there

or use this integration, sometimes easier
when you place those scripts on that folder, you can call the script with a service

Thank you for all the info and tips.
Will give it a try.

I tried to set this up but it’s not working correctly. It will go back to off after trying to turn it on, so the light will turn on indeed but HA things it’s off and it’s impossible to then actually turn it off :frowning:

Value template = false … To the rescue…

Then you can turn something on, while it’s already on… Or visa versa…

I’ll try at some point. I just somehow managed to kill the supervisor while playing with the switch code and I’m left unable to restart HA or any addons