Tearing my hair out... Zemismart Blind motor M515EGBZTN

Please can someone with this blind motor help me

I’ve got it set up with ZigBee2MQTT and it works but I cannot for the life of me set the limits

I’ve seen details online that you press the set and up key but I never get the flash as described

Equally the in box instructions say it needs to be set up via the Tuya app, but I’m sure this isn’t the case

I see that a Border value is exposed (Up/Down/Delete_down) so wondered if they might replicate the app function but pressing them doesn’t seem to do anything (so not sure what they’re actually for)

Can anyone help??

Set up 5 of these and they are brilliant once working… after trying the Tuya app to set them and that failed I discovered that you need to do the following.

  1. Remove from HA.
  2. Pair the remote that came with it.
  3. Use the remote to set upper and lower limits. (On mine as follows)
    A. Put blind in upper position using remote, press the set button (on mine this was on the back) then
    press the up key on the remote.
    B. Put blind in lower position using remote, press the set button (on mine this was on the back) then
    press the down key on the remote.
  4. Add the blind to HA.

Should now work…

Hmm okay, will give that a try - do you happen to have instructions on the remote pairing?

They sent the wrong instructions so I’m done with guesswork!

No worries, so on mine it was select a channel, I just left it on one. Press the motor set key once, it should give you a Ding kind of sound, then press the up key within 5 seconds… Mine did not work at first so I reset the motor by pressing the set key 5 times quickly. Good luck

Are you sure we’re talking about the same device?
Reason I ask is that I definitely have no audio on my blind…

Edit: nevermind, no beep but it bloody worked!
And I didn’t need to disconnect from HA!

Thank you!!

Yeah I found the audio is temperamental, on one minute off the next, that’s excellent news, could you please mark that a a solution, thanks.

Hi Andrew, vaderag

I’ve a couple of the Zemismart blind motors (model M515EGBZTN) but they were bought at different times. The more recent one that I got is apparently v2 hence setting the limits cannot be done via the motor itself and, as vaderga said, the instructions said you need to do it via the Tuya App but I don’t have the Tuya gateway.

I have the blind remote from the first one I purchased but I tried to pair that with the newer model but it doesn’t work. Do you mind detailing to steps that you took to:

  • pair the remote
  • set the limits

Thank you!

Honestly I don’t remember

I never paired the remote - I don’t need it and I got bored of messing about with the device so didn’t want to mess things up!

For everything else I followed this video:

I will say, my experience didn’t fully align with the instructions that are there, but a combination of his instructions and the instruction sheet that came with the device got me there

Thanks for replying vaderag. I too followed the exact same video for setting version 1 of the motor blind. It’s just version 2 doesn’t support setting limits via the device itself. I guess for future if you planning on getting another device, just double check that it is not the new version.