Teepao window cover/shutters integration

Tags: #<Tag:0x00007f73989db0d0>

I had 6.6.1 and with the reflash, updated to 6.6.10.

Since I had those errors, I havent experienced the same again. I will see in the future, if they start to do the same.

I am testing them heavily. It also worth to note, that they were not fitted in their final position, the connection might had been a bit hefty.

Right now they are properly fitted and enclosed, lets see.

Thank you for your support!

Hello linus,

thank you for introducing and sharing your project.

As firmware I used your bin file from post no. 17, 4 small wires soldered to the wifi board (that was actually the hardest!) and then flashed the firmware.

Strictly followed your steps from contribution no. 1, then installed the plugin “slider-entity-row” and called this with the cover - what can I say … just great and therefore a heartfelt thank you.

Then installed the whole provisionally on 1 of my 6 roof windows.

Here is a video of the installation: https://youtu.be/jOmolXXaxwg

After a few weeks testing, the whole will be then installed “correctly”.

PS: greetings from schwabmünchen to münchen

Correction:

As firmware I used the bin file “sonoff.bin” from Stfean Bode (source link)!

Very nice!

greetings from “Niederrhein”

The controllers are working well lately, I am very happy with them. Thanks again for the guidance!

Although I have a small issue… The backlight is very strong, especially for the bedroom. I would like to switch them off, or at least to dim them for the night. They are switched by the ESP when being flashed, so there should be a solution… What do you think? Maybe we should edit the template for this?

Thank you!

You could turn off two LED’s with changing the template to:

{"NAME":"Taopao","GPIO":[255,255,255,18,22,19,255,255,255,21,255,255,17],"FLAG":1,"BASE":18}

Alternatively you can put a piece of paper between the glass plate and the switch.

Greetz!

Hi,

I got a little problem:
I flashed the forked .bin from the post above and followed the instructions from top of the page. It works fine, but the shutter opens with button in the middle (formerly stop). If I use the template from MMeinhard, the buttons work in the correct order, but I have to keep the button pressed to close/open the shutter.

My task is to use the cnfig from Stefan with the button-order from MMerinhard. Could you help me?!?

Many thanks!!

Hi Robert,

I noticed that the templates are not always applied correctly. I don’t know if it was me or the firmware. for me it is like that I only have to press the button once and the roller shutter either opens or closes completely. I don’t need to hold it down.
how did you insert the template?

It seems that I’ve got a different version of that curtain switch, but it has also an ESP board. But I didn’t get it to flash tasmota on it.

Serial debug sais that is has gone to boot mode for flash, but a connection with esptool failed. Tried different baud rates. In another community I found a hint to cut the RX line on the PCB, but even that doesn’t worked.!

To enter flash mode I’ve connected GPIO0 to GND.

IMG_20191223_101700_1|666x500

Hi I am having some issue with HA Mqtt manuel integration.
I have followed th file above but the check config fails.

Component error: payload_open - Integration ‘payload_open’ not found. Component error: position_open - Integration ‘position_open’ not found. Component error: retain - Integration ‘retain’ not found. Component error: state_open - Integration ‘state_open’ not found. Component error: position_topic - Integration ‘position_topic’ not found. Component error: availability_topic - Integration ‘availability_topic’ not found. Component error: command_topic - Integration ‘command_topic’ not found. Component error: payload_available - Integration ‘payload_available’ not found. Component error: name - Integration ‘name’ not found. Component error: qos - Integration ‘qos’ not found. Component error: value_template - Integration ‘value_template’ not found. Component error: state_closed - Integration ‘state_closed’ not found. Component error: payload_stop - Integration ‘payload_stop’ not found. Component error: position_closed - Integration ‘position_closed’ not found. Component error: payload_close - Integration ‘payload_close’ not found. Component error: set_position_topic - Integration ‘set_position_topic’ not found. Component error: payload_not_available - Integration ‘payload_not_available’ not found.

Thanks for helping me

First of all thank you very much for such a good job.
I have two problems and wanted to ask.
The first is that if I put the glass cover on, the push buttons do not work with my finger, if you take off the glass cover and the pulses work perfectly.
if i put the cover on the crsital I just checked that it loses all the settings and restarts
Does this happen to anyone else?
And the second is that when I add the entity in home assistant it appears in gray and the buttons do not work for me. If I add them as a tasmota switch they work but the ideal would be to have the cover with the arrows.
Thanks and sorry for the writing I use google translate

Put the glass first on it and then connect the power to it. So you need putting the glas on it with the power disconnected. That works for me!

Thank you very much for the help.
I did not realize this.
In the end I returned the teepao in amazon and bought some homecube.
The path was even more difficult, cutting a track, etc.
But now I’m already working.