Tellstick initialization error [SOLVED]

Hi all. Completely new to Home assistant, and home automation. Not new to Linux or electronics. Tried but did not like the linux base system. Figured hassbian was the way to go.

Bought a tellstick duo, since I have some old nexa switches and wanted something to get started with. Got the tellstick set up , after some library issues. I can turn swtches on and off with the tdtool.

However, when I add:

  host: core-tellstick
  port: [50800, 50801]

To the config I get this i the log:

2018-01-05 11:31:52 WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds.
2018-01-05 11:32:05 ERROR (MainThread) [homeassistant.setup] Error during setup of component tellstick
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/", line 193, in _async_setup_component
    component.setup, hass, processed_config)
  File "/usr/lib/python3.5/asyncio/", line 380, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/", line 304, in _wakeup
  File "/usr/lib/python3.5/asyncio/", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/", line 83, in setup
  File "/srv/homeassistant/lib/python3.5/site-packages/", line 39, in start
  File "/usr/lib/python3.5/", line 676, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.5/", line 1282, in _execute_child
    raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: 'socat'

Any ideas? I don’t really get what file it’s looking for.

Thanks in advance.

EDIT: I’m an idiot. Just socat package missing from hassbian, should be included though…


How did you install it? Having the same problem

That particular issue is resolved by installing socat, apt-get install socat