Tellstick installation on HassIO

Hi! I’ve just started my conversion from “regular” Hass to HassIO (which seems awesome!).

Any guides/tutorial/tips&trix how to install the Tellstick component? I have a Tellstick Duo with a bunch of 433 MHz switches that I would like to integrate with HassIO…



1 Like

Support come with homeassistant 0.51 release image

Very good! I’ll be looking for the update :slight_smile: Thanks for the answer!

Also looking forward to this!

How will this be accomplished? I see that the hass repo Dockerfile contains libtelldus2-core (here), but still doesn’t seem to actually run the telldus-server, telldusd (I might very well be wrong, I haven’t tested tellstick on the origianl docker image).

Will this style be used for the images as well? …and if so, will telldusd be run in an addon-container?

The reason I’m asking is, if there is some TODO-task of making a tellstick/telldusd addon, I’m more than willing to do so.

Any news on how this is done in 0.51 hassio? I have upgraded but i dont know how to do it.

Doesn’t seem to be in 0.51 hassio?

I would gladly help out if I can. Don’t know where to start though. Anyone have any ideas?I remember it being a bit tricky to accomplish on hassbian. Tellstick is crucial for my setup so i would be really happy if we could get this working.

Very interested in this. The only thing that is stopping me from upgrading to :grinning:
Do you have an estimate on when this could be done?

This topic saved me a potential night of frustration. Is there a special forum related to 433 / tellstick setups? Would love to hear some user setups on how they configured on and all-in-one installer

I’m working off all in one and is 90% working I’d say but have the odd hiccup here and there with sensors not showing.

Example is one dht sensor showing and another not… another is one plug not responding on occasion but this could be down to my tellstick config

ok so went ahead regardless and installed on fresh card and working great bar tellstick. Not recognized as of 0.51.2.

tried adding the repository but not recognized.

Tried adding ps4-waker that i’ve added recently and no dice either. Will revert to all-in-one until I hear they’re sorted.

Good work eitherway. Looks a bit more refined.

Is there a plan for tellstick eventually? You said 0.51 but if there is no plan then why say a release? I don’t mean too ungrateful but a simple answer would be nice.

1 Like

I too am longing for this.

One of the reasons I installed is to be able to automate the telldus live stuff. And because of the rather mixed content regarding home assistant and in the documentation , I was led to beleive that all those hundreds of addons where available to hassio as well.

I assume that I have to reinstall home assistant manually instead to get telldus stuff for now?

I went back to Hassbian. Even though I loved It wasn’t for me without tellstick.

I have to correct myself. I assumed I needed to install stuff. It was included. It does work out of the box, witout any installation. Just added

  keys: ...

to the configuration.yml

No local driver though as in all running through telldus online?

Exactly. It worked from home. Now in the summer house it does not work, but I have not excluded network problems. But everything else works just fine…

No Tellstick-support on
OSError: Error loading shared library No such file or directory

Same error here - installed fresh 0.53.1 on Raspberry pi 3
Using Tellstick Duo - via USB port.

Added following lines to configuration.yaml

    signal_repetitions: 3

2017-09-19 21:16:38 ERROR (SyncWorker_18) [homeassistant.components.tellstick] Could not initialize Tellstick Traceback (most recent call last): 
File "/usr/lib/python3.6/site-packages/homeassistant/components/", line 66, in setup callback_dispatcher=AsyncioCallbackDispatcher(hass.loop)) 
File "/usr/lib/python3.6/site-packages/tellcore/", line 107, in __init__ self.lib = Library(library_path, callback_dispatcher) 
File "/usr/lib/python3.6/site-packages/tellcore/", line 312, in __init__ lib = DllLoader.LoadLibrary(name) 
File "/usr/lib/python3.6/ctypes/", line 426, in LoadLibrary return self._dlltype(name) 
File "/usr/lib/python3.6/ctypes/", line 348, in __init__ self._handle = _dlopen(self._name, mode)
OSError: Error loading shared library No such file or directory 
2017-09-19 21:16:38 ERROR (MainThread) [homeassistant.setup] Setup failed for tellstick: Component failed to initialize.

My problem is, that it need run a service in background. They is not supported anymore from manufacturer. This service will run on every device for “only” user they have tellstick hardware. It is the only hardware they run in this way on all 800 components they will be supported on home-assistant.

I think we have 2 ways to go:

  1. The tellstick component will be updated to start this service on load of that platform. So we can delivery the tellstick stuff inside hassio but it is not active for every user.
  2. We have a tellsick add-on, they run the tellstick service and a small hass instance they push the states into core instance.

Maybe someone have a better idea how we can deliver the tellstick stuff without bad affect for every user.

Sounds to me like option 2 is the most reasonable.
Then the users that want tellstick support will actively have to select to install this add-on.

I would be happy to support this and put in some effort on making this happen.

Unfortunately i am not up to speed on where and how to start in this setup with docker files(?) but i am eager to learn.