Temperature, how to use outlier filter?

I have an Aeon Labs Multisensor 6 that I use to read temperature. It reports this value every 10 minutes. Any time I restart HA, it produces a report of 0 degrees. I want to plot the temperature without the zeroes, so the new outlier filter should be useful.

I can’t get it to work however. My new filter sensor reports 0.0 regardless of what parameters I use for the outlier filter.


  - platform: yr
      - temperature
      - humidity

  - platform: filter
    name: "filtered temperatur"
    entity_id: sensor.aeotec_zw100_multisensor_6_temperature
    unit_of_measurement: '°C'
      - filter: outlier
        window_size: 20
        radius: 7.0

    name: Temperatur2
      - sensor.aeotec_zw100_multisensor_6_temperature
      - sensor.filtered_temperatur
      - sensor.yr_temperature
    hours_to_show: 72
    refresh: 120

History graph:

Additional question: Is it impossible to make the filter sensor use the previous data? I.e. have values instead of the grey bar saying unknown.

EDIT: I have tried to change window_size and radius, but it just gives me zeroes anyway.

No one using the filter sensor function?



Will hopefully fix your issue :slight_smile:

Hello, and thank you!

Will the fixes be included in the next update of HA, or is there something else I can do to get them in now?

I’m still waiting approval and considering the changes involved I would wait :slight_smile:

Alright, waiting for the next update of HA then. Thanks. :slight_smile:

I think there is something wrong with the history graph component. All of a sudden my regular line graphs for temperature and humidity (non-filtered values) turned into bar graphs, showed above the line graphs. unit_of_measurement is set correctly and it worked this morning, but not now, with no restarts in between.

Very weird…

EDIT: After 45 minutes, the bar is gone and the line is back, without me doing anything. :thinking:

Are these changes in the beta version that just was released?

No, still waiting approval:


It’s already in the beta version :slight_smile:

Is this change active in the current version? For me it doesn’t look that way…

Has been since version 0.68.

Can you describe your issue ?

nevermind, looks like i had an error in my sensor data