Temperature sensor deepsleep

I integrated a 18B20 temperature sensor using tasmota and send the temperature using MQTT. Everything works perfectly.
In HA, the temperature is displayed, but after the tasmota goes into deepsleep mode, the value is lost and unnavigable is displayed. After waking up, it appears again,… over and over again.
I’ve read many threads but I can’t get it to work.
What should I do with it ?

Last Will, Testament and Birth Messages :page_with_curl: :latin_cross: :baby: :point_down:

What is MQTT Last Will and Testament (LWT)?

Thank you, that will be the cause.
I have to disable LWT in Tasmota, or in HA…
Sorry, but I can’t find it anywhere…

Maybe here :point_right: MQTT - Tasmota

Thank you, I read this. I can see online in the Tasmota LWT console.
But I don’t know how to ignore this in HA.

Well you don’t. The mqtt broker has the truth and the Last Will and Testament from connecting devices and they will be respected. You need tell your Tasmota device to handle the situation differntly

If you rather seek for a (just works :tm:) solution without mqtt you can give esphome with the native api a try.


Same issue here. I saw the custom sensor config, but according to the documentation of the release 13.1.0 of Tasmota we have new mqtt message. Does Tasmota integration take them into account ?
(or when will the Tasmota integration take them into account ?)