Home Assistant Community

Tensorflow on hassio

#1

Hello !

I have read many things about Tensorflow with hassbian, but it is not so clear about hassio and Tensorflow.

Is it possible to use it with hassio (with last version of hassio 0.86.3 ?
Is there any other face recognition with hassio ? Which one is the best to recognize precise face (with database)

Thanks !

0 Likes

#2

Tensorflow is not available on hassio.

Currently I am running this, will be free for 12 months (5000 api calls a month). Bounding box not implemented otherwise it works really nice.

0 Likes

#3

Hello @M203 !
Thanks for sharing this link :slight_smile:
I am willing to stay focus on Tensorflow (maybe OpenCV), and also looking at running it on a separate raspberry.
the tricky part should be to find a way to link a door automation with hassio, send a request to the other raspberry to test the jpg file to make a face recognition and send back a response to the hassio with a text var of the person who was identify

I don’t know if it’s possible!

0 Likes

#4

I am looking at a NUC. Will run tensorflow on that.

0 Likes

#5

Hey Bonilla,

I thought you may be interested in knowing that Jason Hunter has uploaded a TensorFlow installer to his Hassio Addons repository! Do note this is only for amd64 platforms (it works perfectly with my Intel i7 NUC)!

4 Likes

#6

Thanks @stanvx for the news!
My aim is to run it in a raspberry :smile: (even if the result is done like 5 minutes later)
I’ll check it out for sure!

Have a good day!

0 Likes

#7

I’m thankful for this addon, it seems to install version 1.13 and I need to use 1.11. Any idea how to force it install older versions?

0 Likes

#8

I installed add-on and tensor flow, but when I try to add this into configuration.yaml, hass doesn’t start. What can I do?

image_processing:
  - platform: tensorflow
    source:
      - entity_id: camera.local_file
    model:
      graph: /config/tensorflow/frozen_inference_graph.pb
0 Likes

#9

So this worked for me, but I can’t seem to get the models installed. Do you have a quick guide on how you did it?

0 Likes

#10

Follow the setup process on the tensorflow page.

0 Likes

#11

Will this addon work with a qemux86-64 version of hassio?

0 Likes

#12

Should it work on Pentium G3220? I can’t get it working - when I try to include image_processing in configuration.yaml, hass doesn’t start. Logs doesn’t show anything about tensor flow. Where can I find any solution for it?

0 Likes

#13

Seemed to work for me, running hassio on a nuc, but when I call the scan service, it seems like nothing happens. I tried specifying a file_out file but that doesn’t get generated. No errors either. Hmm.

0 Likes

#14

Which CPU U have in NUC?

0 Likes

#16

I have the i3 nuc.

0 Likes

#17

Ok, solved. I migrated from old Pentium to my spare supermicro server with Xeon E3-1220 and now it works like a charm. Now I have plenty of power. And power usage is lower about 15 W.

0 Likes

#18

Do I need to SSH into the hass.io docker container, or how do I follow the setup instructions?

0 Likes

#19

Do you have a step by step in broad strokes of how you got it set up?

0 Likes

#20

Nope, just documentation. Expect of my CPU issues it was really easy. Now I have TensorFlow based camera recording

0 Likes

#21

Hello , i’m trying to run tensorflow on hassio home assisstant
My setup is : Ubuntu > Hassio supervisor > Homeassistant

I can connect to both through ssh

i would like to be sure i understand correctly :

  1. Can i build tensorflow with bazel on ubuntu ( to get a whl without avx2 ) or it must be done on hassio supervisor?

  2. Shoudl i build Object detection library on hassio or is it gonna work if i do it on ubuntu

3., hassio doesnt have apt-get… so how do i install required library on it ((libatlas-base-dev libopenjp2-7 libtiff5)

0 Likes