Tensorflow - Python 3.9


I just upgraded my virtual env to Python 3.9 (since it will be required soon). On this Python version, the only supported Tensorflow versions are TensorFlow 2.5 or later. - 使用 pip 安装 TensorFlow

Looks like Homeasistant needs Tensorflow 2.3 version and I am getting an error message (see below) and it blocks to restart HA from the UI. Any workaround other than removing image_processing from my installation?

Thank you in advance!

Unable to install package tensorflow==2.3.0: ERROR: Could not find a version that satisfies the requirement tensorflow==2.3.0 (from versions: 2.5.0rc0, 2.5.0rc1, 2.5.0rc2, 2.5.0rc3, 2.5.0, 2.5.1, 2.5.2, 2.6.0rc0, 2.6.0rc1, 2.6.0rc2, 2.6.0, 2.6.1, 2.6.2, 2.7.0rc0, 2.7.0rc1, 2.7.0) ERROR: No matching distribution found for tensorflow==2.3.0 WARNING: You are using pip version 20.0.2; however, version 21.3.1 is available. You should consider upgrading via the ‘/srv/homeassistant/bin/python -m pip install --upgrade pip’ command.

1 Like

you should file an issue on github instead of making a forum post

I am going to, I thought someone solved it somehow, that’s why I asked…

I ran into the problem as well, same scenario as you. Just subscribed to your github issue

Wild guess but modify the line in image_processing that’s calling for 2.3 to include the package you using. Should be compatible. If not…downgrade or remove image_processing until resolved

This could be temporary fix

bumping to 2.5.0 does indeed continue to work :slight_smile:

Edit: PR merged will be in 2022.2