Tesla integration not working

I’m wondering if it’s a two-factor authentication problem on my side or Tesla have changed something in their API, but my integration stopped working today. I had issues with my apps too during the day, now they work, but I can’t log in through the integration


Having trouble with the Tesla integration as well. Although I can log into tesla.com with my credentials, when I use those same credentials for Home Assistant it says “Failed to connect”.


Me too, my integration has needed deleting and reinstalling every once in a while but now it won’t install.

Me too, get “Failed to connect” all the time. First time integration.

Hi, same problem here

Same issue here, started a few days ago and have rebooted, retried, rebooted and retried over and over. Still no luck getting it back.

Same issue here. Stopped working yesterday. Tried reinstalling integration: “Failed to connect”

I read somewhere that the authentication method has changed, Tesla has added an SSO.
Developers have already worked on it for another github project, it should come back soon.


Yep, found the discussion on GitHub: https://github.com/timdorr/tesla-api/issues/260


Idd the authentication has changed.
Teslafi.com posted this https://support.teslafi.com/en/communities/1/topics/16979-tesla-v3-api-tokens
Good to see that there is already development under way, thanks devs!!

1 Like

Same here. Hope they figure it out soon. I was enjoying that integration.

Tesla have updated their tokens to a new V3 version for additional security and to support 2FA. This was the message from TeslaFi:


Tesla recently upgraded their API used to obtain data from your vehicle. This means your current Tesla API Token stored with TeslaFi can no longer be refreshed when it expires in 10 Days.

Please visit Settings->Tesla Account->Generate My Token within TeslaFi.com soon to ensure that TeslaFi can continue to obtain data from your vehicle.

This new v3 Tesla API Token will automatically refresh itself as needed and no further action will be needed.

You can reply directly to this email with any questions.

Thank you,

Who is maintaining this? Any chance for a fix

Same problem here.

Got the same problem.

same problem for 10 days

Same here :frowning:

Same Here. Even changed the password. Please Help!

Tesla updated their auth process, i saw a discussion on Github that people are trying to solve this with a new auth process against oAuth3 that tesla uses now.

Same here. I suppose it was just a matter of time. I want to be able to see the battery status and perhaps set up an automation to remind me to charge the car if I’m planning on driving the next day and if charge is < 50% or so.