Tesla Power wall

i have been trying to add my Tesla Powerwall to home assistant, however with no success.
just get - Failed to connect, please try again when adding the IP address.
any ideas would be greatly appreciated.

@CCOSTAN did you also have a Tesla Powerwall? I thought I saw something in your script revers to it. Maybe you can help Andrew?

1 Like

I’m in thanks. Update of router and now connected. Happy days.

1 Like

@Andrew_Jones1 how did you locate the IP address of the powerwall? I cannot seem to locate it.
I have tried looking at the DHCP leased IP addresses and cannot see it, I have tried to match the ARP -a Mac addresses to the MAC address vendor codes for Telsa without any luck. I have reset my router many times with no luck…
any ideas would be appreciated :slight_smile:

Hi Dave.

I found my power wall was only connected using cellular wifi had failed.

See link below and check it is connected to your wifi. Maybe like mine only working on cellular G4



Andy Jones

Thanks Andy.
I think I have a different scenario. My Tesla gateway is connected via ethernet and not wifi.
I can access the data from the Tesla app on my phone, so I am confident the network connection is working. I just cannot locate the IP address of the device, so I can reserve it in my DHCP scope and then use the IP address for the home assistant integration.

Yes I could also access info on the app but it was only connected using 5G. Cellular
Follow above link and it will show, all connections. What connect and what’s not.
If connected you will find on you router, and name of device is the serial number of the power wall.
If you can’t see it, it’s not connected.
I could not get mine to connect, had to get Tesla to come out under warranty.
If is only using cellular only it does cause problems as only to be used as backup.
Tesla can log in from there end and report on status.
Follow the link above. Device will show all 3 connections. LAN, WIFI, Cell. Greens connected red disconnected
Start there.

Hi all, just had Powerwall (Backup Gateway 2) installed today. I can connect to it just fine on my local WiFi network and log in to the Gateway’s web portal successfully. App also works. But HA integration gives me the same generic error when attempting to add the integration.

Also, the technician had trouble starting up the system but it was because the Gateway needed a firmware update. Powerwall firmware is 1.50.2.

How can I further troubleshoot? There doesn’t seem to be any HA log entries when trying to add the integration…

Edit: Never mind, after the 4th or 5th try, it just decided to automagically start working!

Edit 2: Well, actually, they did a series of firmware roll-backs and roll-forwards because my system was stuck on standby. While I was on earlier versions (e.g. 1.49.x, 1.50.1) the integration worked fine. But now that it has settled on 1.50.2, local API access is disabled. I called support and they told me that was expected. :-1: I submitted a feature request to restore local API access. Has anyone else experienced this?