Tesla Wall Connector Gen 3 RESTful

This is a great integration so thanks for finding these API calls. One question I had though, is what do the numbers for ease_state mean? When my car is idle it seems to be 4, but when charging it seems to change from 1 to 11 to 9. Just curious if there is a mapping for what those numbers mean.

Thanks

3 Likes

I found out that a long press on the Tesla charging port button can enable the maintenance mode on gen 3 TWC (SSID advertisement and changing charging current is possible.
According to some teardown videos there are 4 thinner wires connected to charging port. One or more likely two wires are connected to the button. So it would be possible to install there some wireless relay to enable the maintenance mode one-the-fly. By default this would stop any Tesla charging for the time when button is pressed, but charge does resume immediately. Another option is to disable the actual button by leaving the wires unconnected.

Has anybody tried this yet?

Hi,
i tried the Lifetime api but the Wh values it returns are a bit strange. I made a simple test, used the Lifetime api before a charging session and again right after the charging is ready. The delta between these two Wh readings was aroun 120000 Wh, e.g. about 120 kWh. The actual energy charged was about 36 kWh based on the info from the car. Any idea what unit the claimed Wh provided by Lifetime is?

Can anyone advise on how to interpret this data? I’m surprised to see current & voltage for 3 phases, even though I am using standard US 240 split-phase power. All three are reporting current & voltage during charging. What’s the meaning of Phase A,B, and C?

I’d like to chart KW in use but am unclear which values I should be using.

The unit Wh is correct. I can only assume, but there is something wrong with the way the wall connector measures the consumed energy. I am experiencing similar issues with large non-realistic readings. Looking into the historical data from my wall connector I am noticing that the api reports a large chunks of energy consumed in no time especially when the car was unplugged.

Did anyone else experience similar energy reports?

Is there a way to pilot charging current for gen3 via api? Thanks

5 Likes

Hi Miroslav,

I do have the same spurious power consumptions and I just contacted Tesla and sent them some examples…

Lets wait for their explanation :slight_smile:

1 Like

Hi davrog10! Have you ever figured out how to pilot the charging current for the Tesla wall connector gen 3 via API? I am very interested in it…

Hi Jarkko! Have you ever figured out how to pilot the charging current for the Tesla wall connector gen 3 via API? I am very interested in it…

Hi Oliman,

No progress on that front so far. We have two electric cars, and currently we are keeping Tesla in front of TWC (and with that car controlling the charge happens via car).
On plus side is the capability to use also below 6A currents. Negatives include also no support for other cars (I just had a loaner for 4 weeks).

Summary of different possible ways to control the pilot from charger:

  1. Tesla to publish API, this would be awesome
  2. Reverse engineering from firmware image (I failed here)
  3. Reverse engineering communication between two TWC gen 3 and create virtual master device based on this (I was too lazy to do this properly, with only one charger this requires a lot of iteration)
  4. Set up RPi to join the TWC Wifi and keep TWC in the state where the RPi can change the current
  5. Turn on the maintenance mode on request with the button trick
1 Like

I sent a reminder mail on Friday (after a full week waiting in vain for an answer)… Still no response…

There is no other way to get any support but via mail and they are simply not answering… There is not only an evident bug in the firmware of the company invented “computers on wheels” but TESLA is not even reacting in any way…

Btw: I updated my Wall Connector to revision 21.36.6+g195ba83f335ac2, but the spurious energy consumption will still be reported and accumulate over time.

Update: There was only one jump after the latest firmware update till now… The bug may have been successfully fixed:

1 Like

We have a pair of Gen3 wall connectors with load sharing configured - When sharing is enabled, the secondary unit drops off the local network and I cannot access the API endpoint. When connecting to the local access point to come up with 192.168.92.2 in the wifi config page (despite being connected to it to read the info on 192.168.92.1) in the rather than the one assigned by the site, but I can’t reach that, even via the master wall connector,
Is this a known issue / firmware bug? I checked and we’re still on the 21.36.5 release with no new updates available

1 Like

I don’t have two wall connectors so I cannot test this out. But what I understand you only have one wall connector connected as master to you local wifi then the others connect to the master via wifi. So you should be able to get all info from the master, but I have no way to test this. I’m just curious what you see when you are accessing this address? http://IP_master/api/1/vitals and http://IP_master/api/1/wifi_status (change the IP_master to the master IP address you see on your local network)

Maybe you could post your findings?

You can read about how it works here Gen 3 Wall Connector Power Sharing | Tesla and you can also download the latest firmware (21.36.6)

Yeah, the slave apparently connects via the master (as I can click the “check for updates” on the firmware page without it complaining, but nada info about it showing up on the master vitals or wifi_status API json

curl -s http://blah/api/1/vitals | jq
{
  "contactor_closed": false,
  "vehicle_connected": false,
  "session_s": 0,
  "grid_v": 235.1,
  "grid_hz": 49.878,
  "vehicle_current_a": 0.5,
  "currentA_a": 0.4,
  "currentB_a": 0.4,
  "currentC_a": 0.5,
  "currentN_a": 1,
  "voltageA_v": 2.4,
  "voltageB_v": 3,
  "voltageC_v": 0,
  "relay_coil_v": 11.9,
  "pcba_temp_c": 13.6,
  "handle_temp_c": 8.4,
  "mcu_temp_c": 20.3,
  "uptime_s": 187883,
  "input_thermopile_uv": -110,
  "prox_v": 0,
  "pilot_high_v": 11.9,
  "pilot_low_v": 11.9,
  "session_energy_wh": 0,
  "config_status": 5,
  "evse_state": 1,
  "current_alerts": []
}

 curl -s http://blah/api/1/wifi_status | jq
{
  "wifi_ssid": "REDACTED_BASE64_SSID",
  "wifi_signal_strength": 60,
  "wifi_rssi": -60,
  "wifi_snr": 37,
  "wifi_connected": true,
  "wifi_infra_ip": "192.168.X.Y",
  "internet": true,
  "wifi_mac": "98:ED:5C:REDACTED"
}```

I would think there is some API call for checking the other something like:

http://IP_master/api/1/sharing
http://IP_master/api/1/power_sharing

But I don’t have this setup so cannot check, maybe you could test and try to figure it out then we can add it to the HA integration?

There’s sadlty nothing relatng to sharing accessible on the API, only via the local teslaWallConnector_* ssid connection :frowning:

‘strings’ on the firmware file ism’t showing any new endpoints

1 Like

Sad to hear that! When you say “‘strings’ on the firmware file isn’t showing any new endpoints” have someone cracked the FW and one can see the code, if so could you please send a link to that?

You can search strings quite easily with tool called binwalk. Just download the firmware from Tesla and start searching. But I failed with this path: I could not find any new information. Someone with firmware experience might have more luck.

1 Like

So I’ve two TWC3 at my place… I opened a honeypot hotspot with a raspberry and used Wireshark to sniff traffic while trying to add it through the twc power sharing, I’ve attached the pcap file, maybe somebody has time to look into it.

Thanks in advance :slight_smile:

https://drive.google.com/file/d/1rJ9coC1Z_Wa8TZH5Zmj1llZcgYXbOAmM/view?usp=sharing

1 Like

Hello @Miro_G I have installed a TWC 3 last week, and I am experiencing exactly the same kind of large unrealistic peaks of consumption.

Did you have some clues to get rid of that pics ?

What I intend to do is to use the voltage and current to calcul by myself the instant power and then integrate through a Rieman function but this is very annoying.

Any clues on what happens or how to bypass this will be greatly appreciated