Home Assistant Community

Testers needed for Netatmo climate (multiple thermostats or valves)

#372
#373

I’d like to confirm that netatmo stopped working in 0.92

It seems liek after a restart only netatmo climate is affected.

This is what I get:

Error while setting up platform netatmo
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/helpers/entity_platform.py", line 126, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 416, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/netatmo/climate.py", line 94, in setup_platform
    for room_id in room_data.get_room_ids():
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/netatmo/climate.py", line 342, in get_room_ids
    if not self.setup():
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/netatmo/climate.py", line 352, in setup
    self.homedata = pyatmo.HomeData(self.auth)
  File "/config/deps/lib/python3.7/site-packages/smart_home/Thermostat.py", line 30, in __init__
    self.getAuthToken = authData.accessToken
AttributeError: 'NoneType' object has no attribute 'accessToken'
#374

Does anyone work netatmo in the latest version of home asistant?

#375

I do. Just deleted the pycache folder in \custom_components\netatmo. And restarted. I only have valves. No other Netatmo products

#376

@Baosong_Shan do you know that issue in 0.92?

#377

I have a thermostat and a welcome and both work fine. So it’s difficult to debug when I can’t reproduce it.

#378

Hi,

I have the same issue here.
In my configuration “discover” is active and netatmo is used.
I have valves, present and weather station running.
Since 0.92 my valves can’t be found.
In the log I have the entry
2019-04-26 08:45:52 ERROR (SyncWorker_12) [homeassistant.components.netatmo.climate] No default_home in HomeData.

It worked with 0.91.3 so I think something changed here.

#379

[quote="yan, post:378, topic:58233"It worked with 0.91.3 so I think something changed here.
[/quote]

also for me. i’ve weather sation and valves.
something is changes after 0.91.3

#380

Please try again with 0.92.1 which should solve the issue.

1 Like
#381

got now same error, my netatmo thrmostat disapperared in 0.92

2019-04-27 13:45:23 ERROR (SyncWorker_6) [homeassistant.components.netatmo.climate] No default_home in HomeData.

#382

92.1 fixed the issue for me! :slight_smile:

1 Like
#383

0.92.1 also fixed it for me

1 Like
#384

I’ll probably get a faster answer here, rather than contacting netatmo.

Since 8 hours my netatmo wheaterstation is down. I did not change anything.

Already pulled the plug, reconfigured the main station, restarted my router. Nothing helps.

Do you also have issues with the wheater station (thermostat works fine)?
Server down?

EDIT: they show “server in maintenance” in the app now. So don’t waste your time trying to fix it, it will fix itself.

#385

Hi, I also have the camera and the thermostat and I can not make them work, I’m in version 0.92.2 and nothing. I have not managed to make it work either with the native component or with the custom_component, which I have noticed that the cache does not appear, as if it did not load correctly. Can you help me configure it correctly? Do you have it configured with the native component?

#386

Can you please post the error from the logs?

#387

Thank you very much for your help, I just reset the raspberry to version 0.92.2 with nothing else installed and when I set the camera netatmo. This is my configuration.yaml configuration

camera:
platform: netatmo
home: casa
cameras:
- camara

netatmo:
api_key: **
secret_key: **
username: **
password: **
discovery: false

This is the error that marks me:

Error while setting up platform netatmo
Traceback (most recent call last):
** File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/entity_platform.py”, line 126, in _async_setup_platform**
** SLOW_SETUP_MAX_WAIT, loop=hass.loop)**
** File “/usr/local/lib/python3.7/asyncio/tasks.py”, line 416, in wait_for**
** return fut.result()**
** File “/usr/local/lib/python3.7/concurrent/futures/thread.py”, line 57, in run**
** result = self.fn(self.args, self.kwargs)
** File “/usr/local/lib/python3.7/site-packages/homeassistant/components/netatmo/camera.py”, line 46, in setup_platform
*
** for camera_name in data.get_camera_names():**
** File “/usr/local/lib/python3.7/site-packages/homeassistant/components/netatmo/init.py”, line 204, in get_camera_names**
** self.update()**
** File “/usr/local/lib/python3.7/site-packages/homeassistant/util/init.py”, line 224, in wrapper**
** result = method(args, kwargs)
** File “/usr/local/lib/python3.7/site-packages/homeassistant/components/netatmo/init.py”, line 241, in update
*
** self.camera_data = pyatmo.CameraData(self.auth, size=100)**
** File “/usr/local/lib/python3.7/site-packages/smart_home/Camera.py”, line 49, in init**
** nameHome = self.rawData[“homes”][i][“name”]**
KeyError: 'name’

At the moment I have configured it without the custom_components, to see if it is possible for you to give me a hand since you commented that it works for you and you have the thermostat and the camera like me

#388

Since I’m on vacation I wont have time to look at it but a similar issue has been reported on GitHub IIRC. I’ll take a look as soon as I get home.