TFT upload to NSPanel

I’m getting the following error with ESPHome 2014.4.1 trying to upload a tft file to a sonof NSPanel. I see some similar errors with older configs, but release notes seem to indicate these issues have been filed. I’m using this example yaml and tft file and also get the same result if I rebuild the tft file with the nexion editor. Can someone give me any hints about what the error might mean? Thanks

[22:43:41][C][nextion:128]: Nextion:
[22:43:41][C][nextion:129]:   Device Model:     NX4832F035_011C
[22:43:41][C][nextion:130]:   Firmware Version: 51
[22:43:41][C][nextion:131]:   Serial Number:    41B03401A0BE5155
[22:43:41][C][nextion:132]:   Flash Size:       16777216
[22:43:41][C][nextion:133]:   Wake On Touch:    YES
[22:43:41][C][nextion:134]:   Exit reparse:     NO
[22:43:41][C][captive_portal:088]: Captive Portal:
[22:43:41][C][mdns:115]: mDNS:
[22:43:41][C][mdns:116]:   Hostname: nspanel
[22:43:41][C][ota:096]: Over-The-Air Updates:
[22:43:41][C][ota:097]:   Address: nspanel.local:3232
[22:43:41][C][ota:100]:   Using Password.
[22:43:41][C][ota:103]:   OTA version: 2.
[22:43:41][C][api:139]: API Server:
[22:43:41][C][api:140]:   Address: nspanel.local:6053
[22:43:41][C][api:144]:   Using noise encryption: NO
[22:43:41][C][wifi_signal.sensor:009]: WiFi Signal 'nspanel-dev WiFi Signal'
[22:43:41][C][wifi_signal.sensor:009]:   Device Class: 'signal_strength'
[22:43:41][C][wifi_signal.sensor:009]:   State Class: 'measurement'
[22:43:41][C][wifi_signal.sensor:009]:   Unit of Measurement: 'dBm'
[22:43:41][C][wifi_signal.sensor:009]:   Accuracy Decimals: 0
[22:43:41][C][homeassistant.sensor:030]: Homeassistant Sensor 'current_temperature'
[22:43:41][C][homeassistant.sensor:030]:   State Class: ''
[22:43:41][C][homeassistant.sensor:030]:   Unit of Measurement: ''
[22:43:41][C][homeassistant.sensor:030]:   Accuracy Decimals: 1
[22:43:41][C][homeassistant.sensor:031]:   Entity ID: 'weather.home'
[22:43:41][C][homeassistant.sensor:033]:   Attribute: 'temperature'
[22:43:41][D][nextion:770]: Removing old queue type "NO_RESULT" name "backlight_brightness"
[22:43:41][D][nextion:770]: Removing old queue type "NO_RESULT" name "auto_wake_on_touch"
[22:43:54][D][api:102]: Accepted
[22:43:54][D][api.connection:1210]: Home Assistant 2024.4.4 ( Connected successfully
[22:44:01][D][nextion.upload.idf:164]: Nextion TFT upload requested
[22:44:01][D][nextion.upload.idf:165]: url:
[22:44:01][D][nextion.upload.idf:216]: TFT file size: 273032
[22:44:01][D][nextion.upload.idf:218]: Close HTTP connection
[22:44:01][D][nextion.upload.idf:234]: Updating Nextion
[22:44:06][D][nextion.upload.idf:269]: Upgrade response is [] - 0 bytes
[22:44:06][E][nextion.upload.idf:275]: Preparation for tft update failed 0 ""
[22:44:06][D][nextion.upload.idf:302]: Restarting Nextion

Some more information: The problem is the same on beta and dev channels as well and also the same with the arduino framework.

I figured out I could upload the blueprint tft file from github, but not my file from my local apache server under ubuntu. I then placed the tft file I was trying to upload onto github and it worked.
I don’t see any errors in the ubuntu log when the panel downloads the file from my local server.