The Amazing Vanishing Alexa Media Integration


I’m really confused.

I’ve had Alexa Media configured for a good year or so now and had been using it as a means to sent voice announcements from Home Assistant.

Tonight i’ve been doing some tidying up and I noticed that I didn’t have any devices listed against the Alexa Media Integration so I figured i’d remove it and then reinstall. However, when i’ve come to reinstall it the integration is totally missing.

So far as i’m aware this is one of those cases where you need two components; firstly you need the HACS add-on installing and then once that’s in place you should be able to configure it using the Alexa Media integration.

Can anyone point out what i’m missing please? I can see the add-on in HACS but when I go to add the integration in the settings it’s no longer listed.

Thanks in advance


Try re-installing it from HACS.

Unfortunately that makes no difference.

I tried using the REINSTALL button in the HACS repository and also physically uninstalling, rebooting, reinstalling and then rebooting again.

I guess next thing to try is manual configuration via the YAML and see if that works.

Also tried using an older version of the HACS add-on in case it was something version specific.

If anyone has any more clues then i’d be grateful to hear them.



Ok, so ignore this.

Tried again and it appears now. Strange.