The following components and platforms could not be set up: cloud

Just installed on an early Raspberry Pi Model B, Got the latest HASSbian image release from Github.

On first boot the Web UI loaded with the Invalid Config message:

The following components and platforms could not be set up: cloud

Checking home-assistant.log I could see that it could not install dependency warrant==0.6.1 so I ran the following command:

python3.5 -m pip install warrant

That seemed to successfully install the dependencies that are needed including warrant, after that I restarted the home-assistant daemon and the new output from home-assistant.log still shows the same issue:

2017-12-27 02:12:02 WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds.
    2017-12-27 02:12:06 WARNING (MainThread) [homeassistant.setup] Setup of tts is taking over 10 seconds.
    2017-12-27 02:13:02 ERROR (Thread-4) [homeassistant.util.package] Unable to install package warrant==0.6.1: Exception:
    Traceback (most recent call last):
      File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 594, in urlopen
      File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 391, in _make_request
        six.raise_from(e, None)
      File "<string>", line 2, in raise_from
      File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 387, in _make_request
        httplib_response = conn.getresponse()
      File "/usr/lib/python3.5/http/", line 1198, in getresponse
      File "/usr/lib/python3.5/http/", line 297, in begin
        version, status, reason = self._read_status()
      File "/usr/lib/python3.5/http/", line 266, in _read_status
        raise RemoteDisconnected("Remote end closed connection without"
    http.client.RemoteDisconnected: Remote end closed connection without response

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 215, in main
        status =, args)
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/commands/", line 353, in run
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 749, in build
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/req/", line 380, in prepare_files
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/req/", line 554, in _prepare_file
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/req/", line 278, in populate_link = finder.find_requirement(self, upgrade)
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 465, in find_requirement
        all_candidates = self.find_all_candidates(
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 423, in find_all_candidates
        for page in self._get_pages(url_locations, project_name):
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 568, in _get_pages
        page = self._get_page(location)
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 683, in _get_page
        return HTMLPage.get_page(link, session=self.session)
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 792, in get_page
        "Cache-Control": "max-age=600",
      File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 501, in get
        return self.request('GET', url, **kwargs)
      File "/srv/homeassistant/lib/python3.5/site-packages/pip/", line 386, in request
        return super(PipSession, self).request(method, url, *args, **kwargs)
      File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 488, in request
        resp = self.send(prep, **send_kwargs)
      File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 609, in send
        r = adapter.send(request, **kwargs)
      File "/srv/homeassistant/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/", line 47, in send
        resp = super(CacheControlAdapter, self).send(request, **kw)
      File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 423, in send
      File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 643, in urlopen
      File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/", line 315, in increment
        total -= 1
    TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
    2017-12-27 02:13:02 ERROR (MainThread) [homeassistant.setup] Not initializing cloud because could not install dependency warrant==0.6.1
    2017-12-27 02:13:02 ERROR (MainThread) [homeassistant.setup] Setup failed for cloud: Could not install all requirements.
    2017-12-27 02:13:27 ERROR (MainThread) [homeassistant.components.device_tracker] Unable to load /home/homeassistant/.homeassistant/known_devices.yaml: Config file not found: /home/homeassistant/.homeassistant/known_devices.yaml
    2017-12-27 02:13:45 WARNING (MainThread) [homeassistant.components.media_player] Setup of platform cast is taking over 10 seconds.
    2017-12-27 02:15:40 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting

Any ideas on how to get past this? It seems that manually installed warrant is not being detected.

After this I decided to try on this Pi model B and it didn’t work. Following that I ended buying a Raspberry Pi Model 3 and installed there, everything worked flawlessly that way.