The hass don't updating

in the info page shows the version 0.49.0 (sometimes shows update icon). When I try update says “Requirement already up-to-date” (According to the image). What is going on?

You did restart Home Assistant, didn’t you?

Yes! many times

Did you activate the venv before upgrading?

Yes, with is: source /srv/homeassistant/bin/activate

You should be able to upgrade like this:

sudo apt-get update
sudo apt-get -y upgrade
sudo systemctl stop [email protected]
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 install --upgrade homeassistant
sudo systemctl start [email protected]

It always worked!

Sorry to suggest the obvious.

Please try pip3 install homeassistant==0.52.1.

You don’t get any errors, do you?
What does hass --version give you?

Have you tried clearing the browser cache?

Yes, in other PC too.

I tryed, says “Requirement already satisfied” too, but hass --version returns 0.52.1 how it’s possible?

So, you are running the latest version already. It most certainly is a browser cache issue. Did you try other devices or browsers?

There seems to be an issue with certain browsers. States page blank since upgrade to 51.1

Yes, I tryed in 3 PCs, work PC, home PC and notebook (cleaned cache in all)

try cat .HA_VERSION inside your HA homefolder. the output should be “0.52.1”.

are you running a local proxy or anything caching websites for you?

Shows 0.49.0
(No are running any proxy or caching)
I tryed in 3 PCs, work PC, home PC

Ok. You can uninstall HA and reinstall it manually.

sudo systemctl stop [email protected]
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 uninstall homeassistant
pip3 install homeassistant==0.52.1
sudo systemctl start [email protected]

Another possibility is that you are not running HA from the same place that you are updating.

1 Like

gpbenton, how do I certify myself?

cgtobi, do I need to backup my config files? Or are they not affected?

They are not affected. But in general it is always handy to have at least the config files backed up.