The Huawei LTE integration is not working if the DHCP server is disabled on the router

Hi ! :slight_smile:

Since 3 years I’m using HASS on Rasp Pi 4, and HA is monitoring my Huawei 4G router, with no any problem, never.

Few days ago, I stopped the integrated DHCP server in the 4G router, to install the DHCP addon in HA (+DNS server), to have better settings, more DHCP reservations, …

Then today I noticed that there is an error on the Huawei LTE integration :

I remembered that I disabled the Huawei DHCP server, so I enabled it back. Then I rebooted HA, then… it’s working normally :

I absolutely need to access to the 4G router (at least to send SMS notification in HA).
And I need a better DHCP server, so I need to disable the 4G router’s one…

Do you have any idea, please ?

Thank you.

Any idea please ?

Can you limit the scope of the DHCP-server ?

What do you mean, the range of available IP to attribute?

So you could try to limit the DHCP IP Range to say and setup your other DHCP server to allow

I don’t like to have 2 DHCP servers on the LAN.

I need to manage leases.
I want that only the one on HA is managing the network, and managing lease.
I have to try if HA is giving specific lease for a mac address, if the router’s DHCP could disturb the LAN.

But, my initial question is still valid.
Do you know why the ADDON can’t communicate with the 4G router just because the DHCP server is off ?

Then you are stuck between a rock and a hard place.

Following your idea (thank you), now th scope is limited from .100 to 100 (yes, 1 IP available).

I will look how it’s going.

Thanks very much, I was stuck with this issue since a very long time …