The nws platform for the weather integration does not support platform setup. Please remove it from your config

Sorry for the multiple questions, I’m trying to clean up my setup, I get the following error in the log:

Source: helpers/
Integration: Weather (documentation, issues)
First occurred: 9:12:01 PM (1 occurrences)
Last logged: 9:12:01 PM
The nws platform for the weather integration does not support platform setup. Please remove it from your config.

And yet, a grep nws *.yaml in /config shows nothing, there are also no devices or entities for nws, developer tools shows nothing with nws and there are no integration for nws.

In configuration.yaml, all I have is

  - platform: darksky
    api_key: !secret darkskyapi

I don’t know where or why it’s trying to setup nws. Anybody knows why it’s complaining about nws?


Possibly a dumb question but what happens if you remove (or comment out) the darksky configuration? After a restart does it still complain about nws?

Yep, still there…

Because Apple bought Darksky, Apple buys Darksky . Weather forecasts, maps, and embeds available on the Dark Sky website will also shut down on August 1, 2020.

I have switched to this HACS NWS integration. There is a guide out there on all of the integrations, I however was unable to find it again.

Below are the basics, I use for my weather.yaml package. I do know that when you set it up it will ask for an API key, just make one up or have HA generate one for you, either way it needs an email address at the end of it.
ie… 213iubd3487fb3oicybeco23i [email protected]

    name: Alerts
    - sensor.nws_alerts

    name: Freeze Warning
    icon: mdi:snowflake-alert
    name: Weather Alert Texts
    icon: mdi:telegram
    name: Lightning Warning
    icon: mdi:flash-alert

  - platform: nws_alerts
    zone_id: 'MDZ???, MDC???'

Thanks for the reply, but I’m not usinf NWS hence why I’m confused why it balks about NWS. I used DarkSky for something else though and that might explain why the illuminance sensor no longer work.

Edit: Here’s something I find strange though… Under developer Tools, I see NWS there with a friendly name of ‘nuit’ and yet, under Entities or devices, it’s not there…


Found it!

It’s the HASwitchPlate code that uses NWS in its hasp_demo.yaml and hasp_plate1_p2_status.yaml files that triggered the error. I’m not using the demo (obviously) and the status page so I disabled both. No more nws error :slight_smile: