The old 'stuck on "initializing"' problem

There are several old threads on this already, but no definitive answer. The problem is: when starting Home Assistant the page ‘initializing’ shows indefinitely. It should flash briefly then go to the logon screen.

It seems to be something to do with software versions, but I cannot find a Home Assistant page that says definitely what is supported. Is there one?

In my case I have this on Android in certain cases…

Android 8 + Chrome : sticks on ‘initializing’
Android 8 + Home Assistant Companion : sticks on ‘initializing’
Android 8 + Fully Kiosk : sticks on ‘initializing’
Android 8 + Firefox : fine!

Android 10 + Chrome : fine
Android 10 + Home Assistant Companion : fine
Android 10 + Fully Kiosk : fine
Android 10 + Firefox :

It is not just an Android version issue as it works with Firefox on Android 8, but there does seem to be a compatibility or configuration problem. Can anyone tell me what it is?

Same problem here with the Fully Single App Kiosk and the Companion App…
Also no solution yet…

I had the same problem with my Nexus 9 (With a custom rom) and now with my new Chromebook (it is using Chrome OS but allow to install Android Apps)
After do lot of tests, I could see the problem was that “Android System WebView” wasn’t installed/updated, and because of that the app keeps stuck before the login screen.
To fix it, you only need to install/update “Android System WebView” from Google Play Store and it should fix your problem.


Unfortunately does not work for me.

I also have had this issue on my Fire tablet (Fire OS ever since updating HA to 2023.06 and still an issue with 2023.07

1 Like

Same. Were you able to figure it out?

It seems this occurs with tablets running older versions of Android , and I’m not holding my breath that HA will fix it on their end, nor Google will update Android on my Fire tablet. So, I’m going to accept that my choice of a Fire tablet was a bad idea from the start and replace it with a Samsung tablet since Samsung is remarkable at pushing out Android updates for years after product release.

1 Like

Same problem.
HA runs on Win11 VirtualBox and I tried to access with:

  • Firefox: blocked on Initializing
  • Edge: blocked on Initializing
  • Chrome: blocked on Initializing
    How to fix it please ?

Hey folks, same here, but with Ubuntu 22.04 running HA in docker (self-crafted kiosk).
Chromium is stuck on Initializing. I thought it was lightdm issue, but after reloading it remains the same.
An occasional reboot makes HA show the login screen, but it’s hard to track the logic of this behavior.

Thank you. It helped me. I also turned on the new WebView in developer mode.

What tablet is yours?

This worked for me! Just install webview through the playstore after enabled in subsystem

Here it is:

  1. Activate Developer Mode ind Android
  2. Enter Developer Mode
  3. Activate Multiprocess WebView