The uptime YAML configuration has been removed... and now what?

I did an update to the latest version 2022-10- something. And i get a warning!?
First of all why remove a working feature from HA, I do not get that, it is making things needlessly difficult for not HA/Yaml dreaming coders, it works so why remove it, and now it leaves me and maybe others in the dark of what is exactly changed, how will it effect my HA installation what will fall from the sky no longer working and how to fix it and where?

So first of all what is this: The Uptime YAML configuration has been removed X
second: what actions do need to be taken to solve this
Thirdly: what is broken now by removing this?
fourthly: how to replace this with what so things work as they used to do?
fithly: well name a few other complications by this!
sixth: I have no freaking idea what it says or where to find this! here beneath is the text from the error:

Configuring Uptime using YAML has been removed.

Your existing YAML configuration is not used by Home Assistant.

Remove the YAML configuration from your configuration.yaml file and restart Home Assistant to fix this issue.

Plus there was no mention of this change going to take place in the breaking changes!

Thanks, help appreciated


In your setting / integrations there will be a uptime integration which will have the same name as your uptime sensor in YAML. You can now # out or just delete those 2 lines. The next time you restart the core the warning in repairs will go away.

I did disable this in integrations! But what will now not work ?
Why was it removed in the first place?

Besides when i now check my configuration, i get this weird message, why is it not simple as it was… check configuration and get all correct or fault in yaml somehwere, now i get this “Configuration will not prevent Home Assistant from starting!”
This does no longer tell if there is an error or not only it runs no matter what???

I’m getting same error, but I don’t have any uptime platform defined in YAML nor a sensor with the same name, sensor.time_online.
What can I check more?


Neither had I, for me there was an integration named “Time online” second title “uptime” I did disable this integration?! For what why, I do not know but well I did click ignore error for after restart there was still this fault message, no idea if this is now solved, it is ignored and disabled hope that is it.

Hopefully my ESP Home nodes which some use uptime will not now be crippled!

For what I have understood, you should leave the integration enabled and remove in your YAML code (configuration.yaml ?) the platform: uptime definition as @Spiro mentioned before.

What’s strange for me is that I don’t have any platform: uptime definition in any YAML file

Same here woody, that is why I asked in the first topic, where is it, where can I find it. I checked all my YAML code pffffh did cost me an afternoon, but to no avail. I have no clue what triggered this message at the first place for i have no uptime reference anywhere to be found.
Well I had in ESPHome and did erase all of them, which crippled part of my setup, but even then…

It won’t be a breaking change until 2022.12.0

I have the same error for Moon YAML configuration, which I do not use, and is not referenced anywhere in my config files. Is this a bug?

I had this with both the uptime and moon platforms after updating HA. I had both of these platforms in my config.yaml so I made a backup and removed the 4 lines of code and restarted, and everything still works with my moon phases and system uptime displays on my dashboard.

Ok, strange that I have it for moon, despite that code not being in any of my config files (that I can find!).
I just hit Ignore and the error message is gone for now. We’ll see what happens I guess.

1 Like

It’s alluded to in the above, but I didn’t catch what was meant above (and in a couple other responses here, too). I, too, don’t have platform: uptime in configuration.yaml, either. And I spent a few minutes fine-tooth-combing since Ctrl + F didn’t find anything.

However, I had split my configuration (sensor: !include sensor.yaml) and didn’t think to search there initially. For me, platform: uptime turned out to be located in my sensor.yaml file.

If you can’t find it in configuration.yaml, search subfiles have been split off from configuration.yaml.

I’ve searched in all my YAML files, sensor.yaml included, but I don’t see any platform: uptime definition in any of my other .yaml files

Thanks anyway

I also thought that it’s non existent. But search through all yamls proved me wrong.
I got my whole ha config shared via samba, added as H:\ network drive and added to notepad++ as project