Themes seems buggy

Hi, I try using themes. And I first put them in a themes-dir but now I have the following in my . configuration.yaml:

primary-color: pink
primary-color: blue

(with yaml syntax)
But anyway in the GUI I have “Backend-selected”, “Default” and “dark_theme”. Where do they come from?

I guess you have removed the !include from your configuration.yaml?

!include what do you mean? Now I went to the GUI and the events and fired “themes_updated”, now all is gone. Not event the ones specified in configuration.yaml is there (happy and sad from the tutorial) ?

you need to make sure your syntax is correct within configuration.yaml

i suggest you have a read of the docs

if you have a separate file which contains your themes then you need to have an include in your configuration.yaml, such as explained here
in my case I have 1 frontend.yaml file in the root of my home assistant directory, and my configuration.yaml has !include frontend.yaml
This frontend.yaml file contains my themes. Along with other front end related setup options.

it would probably help if you posted the relevant parts of your config using the correct syntaxing etc.