Thermostat card - displays status wrong

Just wondering what should the correct state for this card displayed when thermostat (Heatit Z-TRM3 /Z-Wave) is turned off?
When I turn the thermostat off the status in the card is “idle”, not “off”.

Show your config for this climate device.

The card working fine for me, but this is probably a different integration. I use the Daikin climate integration, it looks like you may be using the generic thermostat?

Screenshot 2022-06-24 at 11-41-44 Overview – Home Assistant

Also there has been no such thing as “Hassio” for years now. Please stop using that term. It confuses new users.

Your pics confirms my suspicion.
My card config is this, don’t have any other config at the backend:

type: thermostat
entity: climate.floor_thermostat1
name: Baderomsgulv

It might be how Z-Wave JS handles this thermostat(?)

(Removed legacy naming from Headline.)

1 Like

Yeah, I’d open an issue.

Any ide how to download the entire log from the Z-Wave JS Add-on?

In the Z-Wave JS integration there is a download button but in the Z-Wave JS Add-on it looks like you can only copy the latest entries (what you see on the screen not the log from start). Or its the two logs the same?

No sorry I gave up on zwave years ago. When it was a bit shit. Seems a lot better now from what I’ve read but I’ve moved on to zigbee.

Some thermostats do not turn off but instead just set the lowest possible target temperature.

Just nitpicking here, but would be nice of the card displays correct status. Details shows “Idle(Off)” but card shows “Idle”?
In any case the should show “Idle (Off)”

I would probably post those pictures in a bug report or feature request.