Thermostat card – how to set step size


I’ve installed a Plugwise system in my home for climate control. I’ve created a dashboard with Thermostat cards to set the temperature in each room. However, the step size of the setpoint temperature is 0.1ºC. I want it to match the 0.5ºC step size of the physical “Lisa” thermostats that hang on the walls in the rooms. I can’t find a setting to change the step size, neither in the Thermostat card, nor in the settings of the device or the entities. Where can I change this?


In generic thermostat is done like this.

Don’t know, how to on a external thermostat.

precision float (Optional)

The desired precision for this device. Can be used to match your actual thermostat’s precision. Supported values are 0.1, 0.5 and 1.0. This value is also used as the step size for setting the target temperature.


0.1 for Celsius and 1.0 for Fahrenheit.


  - platform: generic_thermostat
    name: Jacuzzi
    unique_id: thermostat_jacuzzi
    target_sensor: sensor.hottubcontroller_air_temperature_9
    heater: switch.hottubcontroller_2
    min_temp: 10
    max_temp: 50
    target_temp: 10
    precision: 0.5
    cold_tolerance: 0.1
    hot_tolerance: 0.1
      minutes: 10

Where did you take that snippet from? The Plugwise integration is fully UI configured, so I don’t have any YAML configuration for the thermostats. The thermostats do support setting the setpoint temperature in steps of 0.1ºC. When I set the temperature to 19.6ºC it also shows 19.6ºC on the LCD display of the thermostat on the wall. However, if I touch the + button on the device, it increases the setpoint by 0.5ºC. I want the home assistant card to also use 0.5ºC, but it uses 0.1ºC, presumably because the device does support this. I can’t find any place to configure this. The thermostat card also doesn’t seem to have a precision or step setting.

Is plugwise the integration?

Yes, the official Plugwise integration.

I looked at the code and it looks like your thermostat may not report a step size, or it outputs a step size smaller than 0.1. So you’ll have to attempt to override it.

Not sure if it will work, but you can add this to your configuration.yaml

      target_temperature_step: 0.5

Some Plugwise thermostats report a precision of 0.1 degree, others 0.01 degree.
The integration overrides the 0.01 to 0.1 because 0.01 would be useless.

Please try the suggested customization.

@petro @bouwew I tried the customization, but it doesn’t seem to work. I added the following snippet to my configuration.yaml:

      target_temperature_step: 0.5
      target_temperature_step: 0.5
      target_temperature_step: 0.5
      target_temperature_step: 0.5
      target_temperature_step: 0.5
      target_temperature_step: 0.5
      target_temperature_step: 0.5

I’ve reloaded the YAML and when that didn’t work, I restarted HA. But the step size is still 0.1ºC. I tried both the dashboard I created, and directly on the entity.

Then it looks like you’re stuck with 0.1. The code in the integration defaults to 0.1 if your device has a resolution lower than 0.1 or if it has no resolution listed at all.

Clear, thanks for your support! FYI: I’ve created a feature request to improve the situation.

@bartkummel please try:

      target_temp_step: 0.5

For some reason this seems to work in my system!

I found this “fix” in a similar topic.

1 Like

Thanks, @bouwew, that works!

I’ve created a documentation PR to add this to the Plugwise documentation: Update plugwise.markdown by bartkummel · Pull Request #32346 · home-assistant/ · GitHub

Please mark my post as Solution, then others can quickly find the solution too.

1 Like