Things broken in 115 that worked before

This used to work before I upgraded to 115.1

Logger: homeassistant.components.websocket_api.http.connection.140052263988240
Integration: Home Assistant WebSocket API ([documentation](, [issues](
First occurred: 3:30:09 PM (3 occurrences)
Last logged: 3:30:23 PM

required key not provided @ data['media_player']

Traceback (most recent call last): File "/usr/src/homeassistant/homeassistant/components/websocket_api/", line 137, in handle_call_service await File "/usr/src/homeassistant/homeassistant/", line 1269, in async_call processed_data = handler.schema(service_data) File "/usr/local/lib/python3.8/site-packages/voluptuous/", line 272, in __call__ return self._compiled([], data) File "/usr/local/lib/python3.8/site-packages/voluptuous/", line 594, in validate_dict return base_validate(path, iteritems(data), out) File "/usr/local/lib/python3.8/site-packages/voluptuous/", line 432, in validate_mapping raise er.MultipleInvalid(errors) voluptuous.error.MultipleInvalid: required key not provided @ data['media_player']

As per your screenshot, you must include the media_player key, the only optional key is ‘format’.

As per your error message, you haven’t included the media_player key.

Without this, homeassistant doesn’t know where to send the stream.

1 Like

Thanks you but I am not sure where to go. I had this automation working before I upgraded to 115.1
I created it with the form and now it does not want to work. I am executing it from the automations tab manually.
I am casting to my Google nest hub.
Any ideas?

 id: '1599094851589'
  alias: FD Camera Line Crossing Cast
  description: Cast Video stream from Front Door Camera when Line is crossed B to
    A direction
  - entity_id: binary_sensor.hikvision_back_door_line_crossing
    from: 'off'
    platform: state
    to: 'on'
  - after: 07:00
    before: '18:00'
    condition: time
  - data:
      entity_id: camera.front_door_camera
      media_player: media_player.den_display
    entity_id: camera.front_door_camera
    service: camera.play_stream
  - delay: 00:05:00
  - data: {}
    entity_id: media_player.den_display
    service: media_player.turn_off
  mode: single

This was the error in the log

Logger: pychromecast.socket_client
Source: /usr/local/lib/python3.8/site-packages/pychromecast/
First occurred: 4:42:49 PM (1 occurrences)
Last logged: 4:42:49 PM
[Den display(] Failed to connect to service Google-Nest-Hub-68b25d73d6ab774c61f8efeb6aea01ee._googlecast._tcp.local., retrying in 5.0s 

I see 2 separate problems.

1). Your developer tools input is not the same as your automation. So it gives an error, that has nothing to do with the error your automation gives.
Your automation show this quoted line as well, while your entry in developer tools is missing that. Just add media_player.den_display under service data and test it.

2). The automation cannot connect to your Google Hub for some reason. Try removing and adding again the Google Cast integration. Make sure to write down the entity_id names so you can rename them after adding. Make sure you restart HA after removing the integration (if it still asks that).

1 Like

Yes I did that and all I got on my Nest was the default media player but no video stream and it eventually times out.

In fact none of my “cameras” coming in from Nabu Casa are showing on the Google Nest. The EUFY Doorbell camera is working on the Nest.

Not quite sure what’s happening

Read my edited message. The problem is not your camera, but your Google Cast display. The error states pychromecast had an error and says it couldn’t connect with that display. Which is Google Cast related. I’d just remove the integration and add again.

Btw: I have some Google Cast issues myself on all HA versions running Spotcast. After a few days, a certain group speaker cannot connect to. Restarting HA solves it. Did you restart HA?

I have

  • deleted Google Cast
  • reinstalled Google Cast
  • Rebooted my NUC-i3 just to be sure
  • checked on portainer that all the containers are running and they are

Still the same problem.
This is all I get on the NEST

I have to say “OK Google Stop” to get it to go away.
Beats me!

Tried a few things


Logger: homeassistant.components.cast.media_player
Source: components/cast/
Integration: Google Cast (documentation, issues)
First occurred: 5:29:52 PM (1 occurrences)
Last logged: 5:29:52 PM
Failed to cast media Please make sure the URL is: Reachable from the cast device and either a publicly resolvable hostname or an IP address 

Looked in Issues (#40273) on this and there appears to be an issue with the external URL and it no longer resolvable.


I just tried to play media (an mp3) using the new media option and selected the NEST and it played the music on the Nest.
The cameras still not working though :roll_eyes:

Looks like the automation and media player part is not broken, but cameras are. I think your issue is related to this: You should report there, so the issue gets some traction.

Thank you.
I have commented in the Github issue.
Let’s hope it gets some traction.

Just reading the latest comments on Github for this issue(#40376) and there are some real challenges to be solved here.

This appears to be the main culprit, Apple’s HLS
The great people tracking this issue are doing great work!

Just to prove this I loaded an MP4 video that I made my with HD video and AAC audio onto the media folder on my HA. I then used the media icon on the side panel to cast it to my Google Nest and it worked just fine.
So they are definitely on the right track.

1 Like

This issue ran deep as Jason Hunter reports on Github #40376.

It requires changes in a lot of places and there have been a number of PR’s (Pull Requests) according to Jason.

Just updated to 115.4. This release fixes the camera stream but does not fix “hey Google … Show me front door camera” This still hangs. Comments in Git hub issue say that this issue is handled by Google cast people. Separate issue has been raised on Git Hub.

The TTS script doesn’t work either 115.4
Invalid MultiSpec data: TextFrame(encoding=<Encoding.UTF8: 3>, text=['cs'])

Has this been fixed for you in 0.116.x @rontaylor?

yes but there are significant time lags on casting. I have tried ONVIF & Generic Camera integrations and most have 7 plus seconds lag when casting.

1 Like

Spotcast issue - Good News. Upgraded version 0.116.2 and it WORKS :slight_smile: again. All casting media players came back and my automations started working again.

So ignore what I was writing here below …

Just to confirm - Spotcast “breaks” the casting of google devices. I tested:

  • Original working Spotcast caused all google home speakers to be unavailable
  • Removed stopcast from configurations.yaml - all chromecast speakers came back
  • Installed fresh spotcast - reconfigured - all chromecast unavailable again
  • comment out spotcast in confi - All working again…