"This add-on does not expose configuration for you to mess with…"

Hey everyone so I’m going a bit crazy here. I am attempting to install Node-RED version 13.4 on a 32GB Pi 4 64-bit using this guide on Windows 10 but having issues accessing the configuration tab in the add-on store, and the install itself is not working. When I hit “start” and then click the node-red tab in the sidebar, I get a 502 bad gateway. Everything is saying the fix is changing ssl to false and adding secret_credentials in the “Configuration” tab, but I can’t do that because on the add-on page’s configuration tab, it simply says “This add-on does not expose configuration for you to mess with…” no matter how many times I reinstall the add-on or restart HA entirely. I’ve watched multiple tutorials on YouTube, but it seems like no one else has this problem with the “Configuration” tab on the add-on store.

EDIT
Also, I tried to find the /config/node-red folder with File Editor like the documentation recommends but it apparently doesn’t exist, there is no folder in /config with anything close to the name node-red.

thanks folks

Hey if you read this and have the same issue, mine was fixed by opening HA in Chrome instead of my usual browser Firefox. Other users around online said it was when they switched browsers, some from Brave to Firefox and others like me from Firefox to Chrome.

Probably a dumb question for me to ask but did you try to clear browser cache in Firefox?

This has changed I believe.
I can’t remember where you find these settings though.
I’ll have a look when I get to the computer.

Make a force reload to avoid the browser cache.
Sometimes it’s Shift+F5, but not always. Check your browser documentation.