This is how i installed hass.io on ubuntu with docker / portainer via ssh


#21

the hassio install script fails to connect with the docker daemon after:

[info] Install supervisor Docker container

Anyone have any ideas why?


#22

Sounds like it failed to install the hass.io supervisor docker. Did you run the command as root user?

You need to go sudo -s
If the command prompt ends in $ you are not root. Root ends in #.


#23

After a failed HASSIO upgrade from 0.85 to 0.85.1 (was working perfectly in 0.85, pressing 0.85.1 update button innside HASS disconnected the client but nothing happened) I started to reinstall all and followed the instructions by the letter, but the container homeassistant does not install. Sorry for cross postiung, but I am a bit opf panick, wish to get it up and running

[email protected]:~# curl -sL https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install | bash -s -- -m intel-nuc
[Info] Install supervisor Docker container
[Info] Install supervisor startup scripts
[Info] Install AppArmor scripts
[Info] Run Hass.io
[email protected]:~# ^C
[email protected]:~# docker ps
CONTAINER ID        IMAGE                 COMMAND             CREATED             STATUS              PORTS                    NAMES
ee3e859e25a2        portainer/portainer   "/portainer"        4 minutes ago       Up 4 minutes        0.0.0.0:9000->9000/tcp   suspicious_albattani
[email protected]:~#

#24

After few minutes (doing nothing) also portainer disappeared …??

[email protected]:~# docker ps
CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES
[email protected]:~#

#25

I think that script is not for re installing.
I think you ctrl+c out of the script before it finished.


#26

thanks for noting, but no, it was just a bad copy/paste, in reality I did not do CTRL C


#27

Great tutorial, now I have just one question. If I install Samba Add-on, everything goes ok, but what if I want to have access to the Hard Drive of my Ubuntu PC? How can I set up a samba share to both?

Sorry for the noob question


#28

I’m not sure if the hass.io samba supports sharing other directories.

An option might be too disable samba share add-on then configure samba share in the host os.

The hass.io directory is
/usr/share/hassio/homeassistant/config


#29

I think I will go that way. disabling the add-on and setup the directory. Thanks! didn’t know what directory was.


#30

Thanks for the reply.

All commands were executed as root. Its obviously something to do with the fact I am using the windows 10 Ubuntu app. There are limitations to the app, such as no systemd. Is there any system dependencies you can think of that would cause the supervisor docker install to fail?

What steps would I need to take to erase my failed attempt and make a fresh attempt at rerunning the installation steps?


#31

how would you go about updating after installing this? will it work via the menu in hassio?


#32

Yes, menu.


#33

Great.
Managed to crash my installation yesterday. Installed Hassio on Ubuntu18.04 following the steps here. So hopefully I can update to 86.2 using the menu without breaking my installation?


#34

Excellent instructions. Worked perfectly…until…

When I click in the addon store for anything eg. SAMBA, nothing installs.
It goes through the process and then says: “Addon is not installed”

any ideas?


#35

I followed your instructions (thanks to frenck) and I now have hass.io working in docker.
If hass.io ever stops working for whatever reason (let’s say a botched upgrade) and I need to re-install do I follow the same commands or are they different?
fyi, I do backup my config directory.
thanks


#36

Cross this bridge when it comes. Issues with upgrades can be handled with via various means. Uninstalling and restoring is not the only or the most effective method of dealing with an issue.


#37

Actually, it already happened when I upgraded to 86.4 and I could not get the gui to show. The log showed no errors. I wasted hours trying to debut but I finally gave up and used portainer to kill of the home assistant containers and then followed the original instructions to install again. I thought that maybe that was overkill and there is a simpler way to recover.


#38

is it possible to “see” USB devices plugged into the Ubuntu machine from dockerised HASSIO?
I want to install this but am worried my RFLINK device won’t work when I connect it to my Ubuntu machine


#39

I can’t check as I’m now using home assistant in docker and not hass.io in docker.

In docker you have to specify privilidged = true or specify the usb address to have access to usb devices.


#40

How do I restart hass.io after a system reboot?

Actually, I am not sure what’s running and what not.

$ docker ps
CONTAINER ID        IMAGE                 COMMAND             CREATED             STATUS              PORTS                    NAMES
38979625382b        portainer/portainer   "/portainer"        3 minutes ago       Up 3 minutes        0.0.0.0:9000->9000/tcp   peaceful_stonebraker
$ docker image ls
REPOSITORY                               TAG                 IMAGE ID            CREATED             SIZE
portainer/portainer                      latest              19d07168491a        23 hours ago        74.1MB
homeassistant/qemux86-64-homeassistant   0.88.2              ec96e9d6a77b        6 days ago          1.17GB
homeassistant/qemux86-64-homeassistant   latest              ec96e9d6a77b        6 days ago          1.17GB
esphome/esphome                          latest              59d062ff82c4        7 days ago          555MB
homeassistant/amd64-hassio-supervisor    145                 a5e7b092ba19        12 days ago         200MB
homeassistant/amd64-hassio-supervisor    latest              a5e7b092ba19        12 days ago         200MB
ubuntu                                   latest              47b19964fb50        4 weeks ago         88.1MB

Everything worked fine until I rebooted. Hardware: x86 with Ubuntu.

Thanks in advance for help with what I hope is a trivial issue.