This Site Can't Be Reached (new macOS install)

Hi all.

Brand new install on MacOS. Followed instructions to the T yet after launching Hass and going to the URL (tried all combinations) just get This Site Can’t Be Reached error (ERR_CONNECTION_REFUSED).

Any idea what could be going wrong? I also tried rebooting.


Few questions:

  • What URL are you using?
  • Where are you trying to open the URL from? (Device on which HA is installed or other machine?)
  • Have you set up SSL?
    The more info you provide the easier it’ll be to understand what could be wrong…

Chrome/Safari browser on local computer.
http://localhost:8123 or http://(local IP):8123.
No SSL at the moment.

This is what it says in terminal (note I had to remove the URLs for posting):

Please check your config. @ 2018-05-03T11:50:31.307773-04:00>, new_state=<state persistent_notification.invalid_config=notifying; title=Invalid config, message=The following components and platforms could not be set up:

  • [recorder]
  • [http]
  • [history]
  • [api]
  • [websocket-api]
  • [system-log]
  • [frontend]
  • [tts]
  • [conversation]
  • [cloud]
  • [config]
  • [logbook]
  • [updater]
  • [discovery]
  • sensor.yr

what do your HA logs show?
If it’s not showing up it could be because it can’t start?
Do you get any error when you type hass --script check_config in a terminal on the machine where HA installed?

Okay I got it working. It was a permissions issue in MacOS. Weird as it was installed with proper permissions.

Thanks anyway!

1 Like

@mrl72 I know that it’s been over a year since you posted this, but I’m facing the same issue and would like to know which permissions you changed, and what you changed them to.


Were you able to figure out? Same issue here.

Unfortunately no. I’ve read multiple posts on how it should work, but I always get an error of some sort. I got frustrated, and ordered a raspberry pi in order to install hass. It arrived last night, so hoping it’s a smoother process.

I ended up giving it one more go using docker, and I’ve had success. I followed instructions from Thibault Maekelbergh.

It was all done with very few commands in Terminal. I set up a folder in my user folder called home-assistant, and then an empty folder inside of that called config. In the home-assistant folder, create a text file called docker-compose.yml with the following code (be sure to set the timezone to your local):

version: '3'

    container_name: home-assistant
    image: homeassistant/home-assistant
      # This is the required way to set a timezone on macOS and differs from the Linux compose file
      - TZ=Europe/Brussels
      - ./config:/config
    restart: always
      # Also required for macOS since the network directive in docker-compose does not work
      - "8123:8123"

# Add this or docker-compose will complain that it did not find the key for locally mapped volume

Follow the rest of the instructions on his site. One thing that may be helpful that he doesn’t cover is how to install homebrew if you never have. This needs to be done before installing docker since his method uses brew to install it. In a Terminal window enter

/usr/bin/ruby -e "$(curl -fsSL"

You will be asked for your password. Once you enter it the install will take about a minute, then you can continue with the docker instructions from Thibauld’s site.