This site can't be reached with private domain


I’m trying to use my own domain name to access my HA. On local, I have been able to access it without any trouble (using this domain name, local IP isn’t working anymore)
But from external access I have some trouble. And I’m struggling to understand what’s wrong.

I tried to reach HA from computers (out of local network), some are working, some not. And on those which are working, it’s not always working on all web browser (mainly Firefox is working easier than Chromium base (Chrome, or Edge)).
I also tried on my phone, it’s most of time working on Firefox, but not on Vivaldi on Chrome. And not on HA application (I’m expecting it will work when I will be able to make it works on Chrome).

Here’s how I set it up:

  • Installation, parameterization and Let’s encryot start-up
    • Here its parameters:
email: [email protected]
keyfile: privkey.pem
certfile: fullchain.pem
challenge: http
dns: {}

The Let’s Encrypt log file indicates the following, So I understoof that it’s fine:

Successfully received certificate.
Certificate is saved at: /data/letsencrypt/live/MYDOMAIN.COM/fullchain.pem
Key is saved at:         /data/letsencrypt/live/rMYDOMAIN.COM/privkey.pem
  • On configuration file, I added following lines:
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  • On Settings \ System \ Network, I wrote then save https://MYDOMAIN.COM on both fields of Internet and Local network

Then I restarted my HA.

Can you highlighted me if anything is incorrectly done ?

Copy these 2 files

to /ssl


On data folder, I haven’t any subfolder
But, on /ssl I correctly have these 2 files

I’m still looking to improve this.
Any support will be appreciated.