Thread Border Router connection issue


I set up a Home Assistant and want to connect my Thread Mesh with my Thread Border Router with it. But when I try to connect them via the HA I receive an error.
The documentation describes, that I need to add an integration with the URL of the TBR. When I insert the URL, I get a “Connection failed”. My Border Router Web-GUI is active via this URL (which is just the IP of the router) and I don’t know of any other possible URL.

With the “Terminal” Add-On I can ping the Border router and the other way around, so they should be visible to each other.

When I use the OpenThread Border Router Add-On to configure my HA also as BR, then I can call the Web GUI of this Router and let it join my Thread Mesh. I use a nRF52840 Dongle to realize Thread. But I don’t think this is the only way to connect the HA to a BR + Thread mesh.

In “integrations > Thread > configure” I can see my Border Router but I can’t select it.

Can anyone help me connect my Thread Mesh with my Home Assistant?

Thanks in advance!

Is IP6 enabled in HA?

On ETH0 yes “automatic”, on WLAN0 not. When I try to activate it I get an unknown error.
But my HA is connected to the Router with Ethernet.

Maybe that is the issue - and unfortuntely That is the limit of my knowledge on this subject (maybe unrelated but I do have a Matter light switch and matter is supposed to be IP6 but I don’t use IP6 and it works with the Matter integration just fine anyway - so you may or may not have the same kind of situation.)

Okay, thanks for the food for thought!
I’ll look into that.

I got WLAN0 to work, so my HA is connected via Wifi. But I still get the same “Connection failed” when I try to insert my Border-Router-URL (with the IP).
DId anyone also have a similar problem or am I missing something here?

What kind of TBR is it?

My Border Router is a RaspberryPi 4 Model B and my HA runs on a RaspberryPi 3 Model B+

Was checking to see if it was the esp32 implementation of Open Thread Border Router or some third party like an Amazon Echo etc.

In case it’s something esoteric like a known issue between the thread integration talking to an esp32 otbr. The exact software and version may become important here. So what exact kind of TBR is it?

It’s a RaspberryPi 4 Model B running Debian GNU/Linux Version 12. Connected is a nRF52840 Dongle to make it Thread compatible.
If this is what you mean. Sorry I’m pretty new to this topic.

What software is driving your stick - meaning Debian alone isn’t what makes it a TBR

My Dongle is a RCP for the Raspi. In my BR-Web-GUI it says
“OPENTHREAD/thread-reference-20230706-223-g75694d286; NRF52840; Dec 1 2023 08:19:44” as RCP-Version

1 Like

Ok i have to find it. But there a thread here somewhere pointing to an issue where one implementation fork of OTBR (the one used by a particular expressif/esp32 standalone OTBR) added something that is not in the HA OTBR addin and it causes weirdness… (edit:it’s actually an upstream change espressif didn’t have in thier version)

Here’s the link to the bug report
Add support for ESP Thread Border Router · Issue #61 · home-assistant-libs/python-otbr-api · GitHub. And it links to another I have not read yet…

In short in that one (may or may not be your issue) it’s something that had to be fixed upstream on the api. (and I had just started reading the threads to see how it exhibits) This smells similar to your issue but without knowing EXACTLY WHAT FORK of the api code you’re using and where it came from we can’t be sure. (thus all the dumb questions.)

There is no such thing as too much info.

Yours may or may not be related to the underlying issue there but notice this is more than ‘can I see it?’ there’s some deep dark black magic stuff happening down in the apis here that minor version differences are impacting stuff. (and why I personally still consider Matter very beta and not ready for primetime… But hey we gotta find the breaks somehow to fix them)

Id read the issue In the bug link above and if that’s not yours you may want to consider opening your own.

(while you are not on a standalone esp32 otbr you’re still running otbr just not the HA implementation of it and your report seems very parallel to the one in that link. If it’s not that I’m sure the core team still wants to know if they have an issue)

Here’s the relevant statement…

So the way I read this… it means someone added code to the api upstream and if the particular fork of OTBR you’re using has not imported those changes there may be issues communicating at a protocol level.

Note ‘potentially other ecosystems’ read anything else using OTBR

So I think I found a way to connect my TBR to my HA, which was my main goal. At least when I look up the routes for the HA with “sudo ip -6 route show” I can find an address that points to the Border router, so I think they are connected.
I did this through setting the Border Router Network-configuration to the Home Assistant Network.
In my devices-list I still can’t see the Border Router though. So I’m not sure if the connection between BR and HA really worked or not?

1 Like

I don’t think you’ll see a TBR in the devices list. However if you go to the Integrations->Thread, click on “CONFIGURE”, you should see it.


Yes I can see it there. I just wasn’t sure if that is enough to be sure that they are really connected.

One more question: Can I put my TBR onto my dashboard in any way?
I can only find an option where I can put the TBR-Add-On on the dashboard.