TileBoard - New dashboard for Homeassistant


#1207

Guys,

I use TYPE.CLIMATE to set temperature on my EQ3max thermostat. The problem is that when I manually set up temperature from HA dashboard i use “+” to set temperature at then it’s applied to thermostat - so far so good.

Using TileBoard when I press “+” the new (+1 degree) value is set on thermostat right away and it’s applied in around 2-3 seconds. In this time I’m not able to change temperature. So for instance when I’d like to set up temperature 5 degree higher then current value I have to press +1 degree button, wait for 2-3 seconds and then pres +1 once again. It’s pretty annoying.

Do you have any idea how to make it faster - for example set temperature and then applied in on entity? Maybe I’m missing something…


#1208

Looking for some help with my thermostat tiles. These were working until recently and I am not certain what changed. Code and screenshots showing warning are below. I appreciate any ideas.

thermo

{
                     position: [1,0],
                     id: "climate.main_floor",
                     type: TYPES.CLIMATE,
                     unit: 'F',
                     state: function (item, entity) {
                       return 'Current '
                         + entity.attributes.current_temperature
                         + entity.attributes.unit_of_measurement;
                     }
                   },

                   {
                       position: [1,1],
                       id: "climate.upstairs",
                       type: TYPES.CLIMATE,
                       unit: 'F',
                       state: function (item, entity) {
                         return 'Current '
                           + entity.attributes.current_temperature
                           + entity.attributes.unit_of_measurement;
                       }
                     },

#1209

Is there any way to display which ‘mode’ the house is in?

I don’t use scenes due to a technical difficulty with LightwaveRF devices, but I want to have say three ‘modes’ that I can put the house in. Day mode, evening mode and night mode.

I kinda do this at the moment with automation firing scripts for the lighting. but what I want to do is have the current ‘mode’ shown on my tileboard. say with 3 buttons that remain highlighted depending on which mode has been triggered / the house is in.

|I realise that this is a little more general configuration, but as I want to display it on tileboard, I guess it falls into this too.

Would love some pointers to get this working!

Cheers
People


#1211

I have just downloaded the most recent files from GitHub and I’m having trouble accessing it.

I noticed that the new config.js file doesn’t have a password anymore?!? Is this an issue?!
This is the screen that I get?!?

18


#1212

Did you manage to resolve this? I have a similar issue. Think I need an authToken, but no idea how to do this?!?


#1213

Hi Martin,

It was a cache issue in Google Chrome…
Whenever I change something in the config.js I have to clear the cache and reload the page.


#1214

I don’t think this is something to do with TileBoard itself. All we do is send the command via API.


#1215

You could use INPUT_SELECT with one tile reflecting current mode


#1216

Yea I figured it out that it working as supposed to. The idea is that how to first setup temperature then send API request to HA.


#1217

Hey @resoai
I recently found beautiful concept graphics for Home Automation:

It’s kindof Google Material Design. I think that building such skin in the TileBoard shouldn’t be too hard, what do you think about it? Worth doing?


#1218

Looks very fresh. I’ll be more than happy to include it if anyone will take time to create it. Unfortunately with recent developments in my life I have little to no time to do anything.


#1219

I presume that climate component is no longer exposing unit_of_measurement in the attributes. You can simply replace it with ‘F’:

                     state: function (item, entity) {
                       return 'Current ' + entity.attributes.current_temperature + 'F';
                     }

#1220

Maybe a longshot, but…

Is anyone here using Fully Kiosk Browser on a Android tablet with TileBoard?
My tablet have been starting to flickering when showing TileBoard, no other site is flickering.

Anyone with a clue? :smiley:


#1221

I think the majority of us are using Fully. I have it running on four tablets and no issues at all. Are you sure its happening only in Fully?


#1222

I’m running it on two tablets: Nexus 7 (1st gen) and Fire HD 8 with no issues and I don’t think that flickering could be an issue of TileBoard.


#1223

It worked as a charm 3 weeks ago.
But it’s only TileBoard that is flickering in Fully… It’s very strange, I think it was when I set up the camera. But I removed it and it still flickering…

Thanks.


#1224

Only in Fully,

In Chrome it works.


#1225

I have the same issue with my Nest it would indeed be nice if it functioned this way.


#1226

Running on 2 Fire 7’s and 2 Fire 8’s no issues with flickering.


#1227

have you tried clearing Fully’s caches or maybe reinstalling?