TileBoard - New dashboard for Homeassistant


#1932

That theme is awesome! Are you planning on sharing it when you finish?


#1933

@resoai is it possible to amend the TYPES.DOOR_ENTRY function ?

I want to be able to click on a tile and bring up a popup of options that can run switches, scripts etc however I don’t need the camera view.

I have removed the following section but taking that out just stops the pop up working at all

					camera: {
						type: TYPES.CAMERA,
						id: '',
						refresh: 1500,
						bgSize: 'cover'
					 },

Any advice would be helpful.

Thanks


#1934

I’m afraid camera is the only mandatory part of doorentry tile. You can always for the project and make your own tile based on it. I’m afraid I’m not able to provide much help at the moment due to health issues.


#1935

Thanks for getting back to me @resoai, will need to do this one the hard way lol

Hoping you have a quick recovery whatever it is.


#1936

Anyone have any issues with IOS 12 and tileboard? I have mine set up and working perfectly either on desktop, or fire 7’s, then if I go to load it on either my iphone or ipad I just get the green background with no tiles… I’ve tried editing the config for _COMPACT/_MOBILE etc and done the auto tile size in the setup instructions, but it’s almost like it’s not being served a page/.js file it needs… I’ve tested this in safari, chrome & firefox.

cheers,

EDIT: Definitely compounded the issue to IOS, have tested on my android work phone both using internal IP and external DDNS and this loads it fine, icons a bit skewiff but actually seeing the pages… is anyone still using tileboard on IOS and if so what browser or is there anything you’ve had to change either phone or config wise?


#1937

Can you share how did you set up the Samsung TV tile. I use TYPES.MEDIA_PLAYER but can only turn it off. On/Off works ok using samusng tv component in HA.


#1938

Hi, thanks, it’s not really that different to the HOMEKIT theme already included, just with some CSS changes to the custom.css file.

It’s still a little glitchy right now and has a few issues, mainly because I’m new to CSS, but if I ever get the issues sorted out then I’ll post my custom CSS on github or bitbucket.


#1939

I’ve tried this on Safari & Chrome on the iPad and once the screensaver has been active the camera thumbnails definitely get stuck and don’t reload. It doesn’t happen when I force start the screensaver at all, but only when the screensaver starts after the timeout (mine is 10 minutes). I would simply refresh the page but since I’m in full screen mode its impossible to refresh without restarting the app.

Edit: Investigating to see if this is a HASS connection issue rather than a TileBoard issue


#1940

Its working fine for me in iOS12 on an iPad Air 2nd gen. It works great using Safari & Chrome (see my previous posts above as to what it looks like). Try clearing your browser cache on the iPad and quit & reload


#1941

Thanks for the reply Ryan, I have tried clearing the cache and to be fair I usually test in new private browsers so that it doesn’t cache… still not working though :frowning: it’s odd, I don’t even get redirected to the login page, it just loads to a blank green background (similar to the background on my dashboard) it does this on my Mac, iPhone & iPad, yet works on windows, fire 7 & a Xperia! The only notable thing is earlier I got the console up on the Mac, the ‘request full screen’ is usual as I get these on the win os in chrome, however the one I don’t get and what I think is causing the issue is ‘’undefined is not an object (evaluating…’ it does this for any of the variables at the beginning of the config.js, originally it was the CUSTOM_THEME_MOBILE one so I tried hashing it out and it does it for each one​:sob:


#1942

Have you enabled debug: true in your config.js? You shouldn’t be taken to any login page if you have a valid authToken in your CONFIG. Also is that your iPad connected to your computer to view the developer tools or is that running a simulator? I would stick with a null theme for now to simplify things.


#1943

Try this instead:

filter: function (value) {return parseInt(value)},


#1944

If you throw:

left:auto !important;

into the code @apop mentioned above, it will work.

The original CSS in themes.css specifies the left attribute, so you can’t just specify a right attribute and have it work without also specify a new value to overwrite the left attribute as well.


#1945

Good call, thanks @aRVAthrowaway!


#1946

Hadn’t seen that, I have enabled now and will give another go looking at the debug when i get home to my mac! I have a NULL for auth token, on my WINOS/android devices it forwards me to the HA login page, after entering the info it forwards back to the dash! That was just trying to access through safari on the mac itself, I can try with web inspector later. I tried with a null theme and still the same, although it may be clearer when looking through debug

cheers,


#1947

Updated my MacOS and tested the dash again in chrome, works fine… still doesn’t work in safari and still won’t work on my phone in chrome OR safari :confused: I used web inspector and it was that same undefined error, I’ve been reading up and people said it’s when it’s called the script Before it’s loaded… although not sure what else to do from here


#1948

That might be your issue, go to your Home Assistant profile page when logged in http://hassio.local:8123/profile and create a Long-Lived Access Token, its the last section on that page. Once you create that token, copy it and paste it in the config authToken section and give that a go. Safari has no way to redirect you from this JS app running in the browser to the HASS login page whereas your browser may be able to.


#1949

Ah brilliant cheers, I think that’s solved one problem, I’m not getting the variable not defined error anymore, I figured out it was spitting that out as it wasn’t running the app.js script, so I’d pasted it into my config.js and that got rid of the error, I’ve just put the token in and cleared cache on both iPhone & Mac and ok getting the torquise screen :frowning: although this has got rid of the variable not defined too now (as I’d reverted before testing the token) so we’re getting closer, it’s hitting the app.js with that, just can’t figure out why it’s not displaying! :frowning:


#1950

Can you post your config.js file between these two lines (the top of the file until your first pages: block):

var CONFIG = {
...
...
   pages: [

#1951

Sure, I’ll post it below, one other thing, I must’ve left a tab open when I cleared my cache as I’d gone to do it again and the auth token was spitting out these errors below, so that could still be the issue, just don’t know why it doesn’t seem to like it, i followed your steps above generating one and inputting it in, does it need to be encapsulated by commas or speach marks as I’d just pasted it straight in? or could I be missing something else in my config either tileboard or HA:

Uncaught ReferenceError: LONGLIVEDTOKENSHOWNHERE(uptothefirstfullstop) is not defined

File: http://192.168.1.113:8123/local/tileboard/config.js

Line: 18:15

Uncaught TypeError: Cannot read property ‘wsUrl’ of undefined

File: http://192.168.1.113:8123/local/tileboard/scripts/init.js

Line: 23:27

Thanks for looking Ryan