Time based automation not going

automation
Tags: #<Tag:0x00007fd072fa5ba0>

#1

Trying to have based off time one of my wemo turns on. I tried miltary time and standard time and both not work. I have googled and watched youtube and matching simliar to what is on there but still nothing…

Also how do you delete a automation?

id: ‘1552594887733’
alias: timebase
trigger:

  • at: ‘8:35’
    platform: time
    condition: []
    action:
  • data:
    entity.id: switch.washer
    service: switch.turn_on

#2

This should work:

- id: '1552594887733'
  alias: timebase
  trigger:
    platform: time
    at: '08:35:00'
  condition: []
  action:
    service: switch.turn_on
    data:
      entity_id: switch.washer

EDIT
Corrected typographic error in automation.
Replaced entity.id with entity_id


#3

How does it know between AM and PM? Does this use military time?


#4

Yes it uses 24hr time…


#5

For some odd reason its still not running. Very depressing.


#6


#7

OK that looks good. Check the entity_id in dev tools…

Does it work if you trigger it manually?


#8

This works fine.

33


#9

OK so the only other thing is the Time zone Settings… is your clock right?

When I asked if you can trigger manually I meant trigger the automation manually. If you have it on a lovelace card, tap on it and there is a link to Trigger… just to check the automation is right…


#10

In Config it shows… time_zone: America/Chicago which is correct I’m in central.

Not sure where to check the automation sorry.


#11

Click the overflow menu (three dots) then click Unused entities.

Overflow%20menu

Overflow%20menu%20-%20Unused%20entities

You will be presented with all unused entities and your automation should be there (and turned on). here’s an example:

Example%20automation%20UI

If you click the automation’s title you will be presented with a popup containing more details. The popup also lets you Trigger the automation manually.

Example%20automation%20UI%20-%20more%20detail

For the clock time, go to the Linux prompt and enter the command date. It should reply with your correct local time. If it is incorrect then it needs to be set correctly (or there is a problem with the DST setting).


#12

should maybe check if the automation is ‘on’, and for security add initial_state: true

or has that been tackled already, in which case I overlooked and apologize…


#13

I flipped these switches on and off a copy times and nothing happens.

new


#14

I checked time and I have same thing on my PCnew2


#15

Flipping those switches just turns the automation on/off, it doesn’t trigger them. Have a look at my previous post, I revised it and added more information.


#16

@Mariusthvdb this is all I have in the config that deals with automation.

automation: !include automations.yaml


#17

my remark to add initial_state: true is for each individual automation see https://www.home-assistant.io/components/automation/ at the bottom


#18

@123 here is this. This does NOT work.

222


#19

That is in automations.yaml right?


#20

not necessarily. It is in each and every automation you declare in the file(s) where you write your automations, see here for more explanation https://www.home-assistant.io/docs/automation/#automation-initial-state