Time Triggers not firing [Solved]

Assistance please with figuring out why some time triggers work and some do not.
Below is an example trigger I made yesterday, that did not fire today.

- id: '1603417395684'
  alias: Buggery_01
  description: ''
  - platform: time
    at: 05:51:00
  - condition: state
    entity_id: binary_sensor.workday_sensor
    state: 'On'
  - scene: scene.wakeup_01
  mode: parallel
  max: 10

In the example docs, it lists a quote. The built in automation editor does not input a quote.
HA Trigger Docs

Other online examples from the forums show a single tick ’ ; This does not reliably help either.

Curiously enough I have other automations that work just fine. I have one that turns on a particular light 15 minutes prior to sundown that works, and if the sun is up for longer days, I have another automation that kicks the light on at ‘18:45:00’ …single tick, and it triggers just fine.

Can somebody explain to me why the editor doesn’t put in any quotes or ticks, manually putting in a tick works on some but not others, and why manually editing in quotes or ticks doesn’t seem to make any difference? The same triggers happen or don’t happen. I just made the examples shown above, 1 minute off the originals, just to see if manually creating a similar one would trigger ok.

Automations are on. States are on. system has been rebooted and rebuilt, check configs say the configs are fine, I am just really at a loss.

Begging for any assistance. I’ve searched, tried everything I could find, and rebuilt the server several times.

'On' in your condition needs to be 'on'. States are case sensitive. Always use the state you see at developer tools > states

1 Like


Is this word in some language other than English?

Because it’s an English word whose meaning is something that is difficult to imagine how it’s associated with home automation.

A buggery is a place to keep bugs. Like an aviary is where you keep avians.


And a buttery is where butter is stored!


Well slap my ass and call me Charlie. Thank you!

I have stared at this and tested it 9000 times, and could never figure out why sometimes it worked and sometimes it didn’t.

Perhaps one day we’ll have logic built in that makes 1==True==true==On==on

The end of day automations always worked because the end of the day doesn’t matter M-Fr or Sat/Sun. I kept getting hung up on the ’ " or plain. Sometimes I even had the time listed prior to the trigger method…

I think I’ve finally got it working correctly. Thank you Sir! … now I can finally remove this bulb from the place it feels like it has been.

1 Like

You’re welcome Charlie :wink:

1 Like

… and an apiary is where you keep apes.

Seriously, there’s only one English-language definition for buggery and I would never have imagined it used for an entity name (let alone four entities). Is it a word in another language?