Time zone in mobile app is incorrect

Hi guys,

I reinstalled my HASS 2days ago, the time displayed on mobile app(UTC time) was incorrect since then.

The time display on computers(accessed from browser) is correct(+08:00), while the display on mobile app(iOS & android) is incorrect(+00:00).

HASS version: 2021.10.2
host time zone: CST

1 Like

I am having the exact same problem since updating HA. On iOS iphone, HA_app, Safari, and Chrome all show time and charts in UTC (whereas a few days ago, this was not the case), but when connecting to HA via a PC Chrome browser all time is in the correct timezone (UTC-6 for me). I too updated HA and noticed the problem, HA_OS, and HA_app are all now up-to-date (core-2021.10.4, Home Assistant OS 6.5, App: 2021.8 (2021.216)).

Looks like the breaking change for me was going from core_2021.9.7 to 10.1.

1 Like

Yes, exactly the same.

BTW, the timezone on iPad Pro APP is correct, is this a bug or something wrong with my config on the mobile APP? It’s really annoying.

I am in the same situation, from web browsers it shows correctly,but from the app I have two hours less.I have installed the app on two phones and a tablet and the same thing happens.I have put the time sensor and it correctly shows the time in the state,however in the registry it shows everything as if it were two hours before.Scheduler card dont work correctly among other

has anyone here opened a frontend issue yet? if not I suggest you check for open issues and if one doesnt exist file one

It seems that it has something to do with incompatibility for older versions of software. My iPhone with iOS 15 displays the page correctly meanwhile my iPad with iOS 14 does not. People have mentioned updating their browser or upgrading their OS solved the issue.

I found this one: https://github.com/home-assistant/core/issues/57417 , and mentioned this thread.

Because this issue would appear if only the HASS core was updated, and all the clients, browsers(on mobile device), iOS APP, Android APP would be affected.

I downgraded my HA with:
ha core update --version=2021.9.7

and the timezone issues went away (I noticed the problem on 2021.10.1 and 2021.10.4).

Here I have the correct time on iPhone [ iOS 14.8 ] and a wrong one on iPad [ iOS 12.5.5. ].
Same core, 2021.10.5, and same Companion App, 2021.10 (2021.247).

1 Like

Same issue here. My fire HD 10 (both companion app and fully kiosk) are on UTC. It’s an issue for the weather display mainly. Other devices seem unaffected.

Confirmed that downgrading to 2021.9.7 fixes the issue. So now I’m in ugly position of either being stuck with an out-of-date HA Core, or home panel on the wall with custom mount that I can’t upgrade (Fire HD 10, stuck with webview that amazon gives me) displaying the weather from half a day ago. Boo.