Timeout while loading URL for WebRTC camera

I have the dockerwyzebridge add on. It provides me a WebRTC link to my camera. Putting the URL into my web browser produces the feed. Putting same URL into generic camera field gives me an error.

I don’t think that generic camera supports non rtsp streams such as webrtc in you case.

I would check go2rtc.

Do you use go2rtc. I started reading the github, but man that is information overload for me. I installed the add-on but now its asking for a password to get into the UI. WHat password does it want?

I would not distract myself with sheer size of advanced stuff.

Just install it, use web ui (port 1985) to access configuration and add your webrtc camera there.

You can expose it using webrtc card (from same developer)

I have been tinkering it for a long time but on a different purpose to integrate it with my own custom integration

When I go to the go2rtc add on and go to webui, it wants to take me to port 8123 and asks for a username/pw that I dont know what it wants.


I tried putting in user / pass, as shown in github, but didnt work.

hmm, it requires your current browser session to have a valid home assistant user cookies. I believe, it is about it :slight_smile: I do not know

Above trick I have tried as well, but I receive a time-out.

In an iFrame the following link is working:

type: iframe
url: >-
title: Hinterglemm Tal - 1.070m

This is working fine in a browser (e.g. Safari). But when showing the Lovelace on an iPad I get after a while “HTTP State 404: not found” .

And the odd thing is, on a prior version on HA a year ago, it was working…