Timer Restore

I am starting to use timers instead of delays now. Love how it is working but the issue is that the settings Restore? does not stay on when saving. I had to manually go to the “\\config.storage” folder and set the value to true. I did a Replace All function in Notepad. Now it works after a restart. I looked at the logs (maybe I am not looking at the right one) and I can see where the changes are made, but nothing about Restore. So, I am not seeing what the issue is in the GUI.

Initially, all timers were created in the GUI and before I knew what Restore was, I did not turn it on. I went through all of them and turned in on in the GUI so that if HA restarted for whatever reason, it simply continued with the timer like it should. Any idea of why the GUI Restore is not setting to true? I will use the “timer” file for now until this can be reviewed.

Thank you.

There’s an issue open for that:

And mind this related issue too: Timer config not applying default duration after an HA restart · Issue #94908 · home-assistant/core · GitHub.

Yes, it was. It always worked until maybe 2024.1 release; I think.

  • Core 2024.3.3
  • Supervisor 2024.03.1
  • Operating System 12.1
  • Frontend 20240307.0

I am running HAOS on the Beelink mini-PC, not on RasPI. I started out with a Mini-PC because Raspberry PI was hard to get. Glad I didn’t start with that because I am barely using the resources of this machine. Got over 100 devices, about 80 Zigbee.

Since I updated the RESTORE file in the config folder, no issues since. It just does not update my changes when

The problem

I enable “restore” when I create a Timer helper, but this option is not saved. The same behavior when I try to modify an existing Timer helper.

What version of Home Assistant Core has the issue?

Core 2024.3.3

What was the last working version of Home Assistant Core?

I did not start noticing this until February. Sometime in 2024.2.*.

What type of installation are you running?

Home Assistant OS, directly. No container.

Integration causing the issue

Timer (only in GUI)
Setting it in the config folder holds the setting.

Link to integration documentation on our website

Diagnostics information

No response

Example YAML snippet

This is only a part of the “timer” code.

  "version": 1,
  "minor_version": 1,
  "key": "timer",
  "data": {
    "items": [
        "id": "ibuprofen",
        "duration": "8:00:00",
        "name": "Timer Ibuprofen Antonio",
        "icon": "mdi:pill",
        "restore": true
        "id": "acetaminophen",
        "name": "Timer Acetaminophen Antonio",
        "duration": "4:00:00",
        "icon": "mdi:pill",
        "restore": true
        "id": "timer_acetaminophen_serenity",
        "name": "Timer Acetaminophen Serenity",
        "icon": "mdi:pill",
        "duration": "4:00:00",
        "restore": true

Anything in the logs that might be useful for us?

Honestly, I did not see anything. When I set the timer, it shows that it is saved, but that is it. No instance of the restore. To be real honest, I may be looking in the wrong place.

Additional information

The restore timer works when changing it in the config folder. Above, it may look like it never works, just not working all the time. I would say 60%, I would check Restore? and it does not save. 40%, it works. Here is one more thing to add. If I add it for a new timer, check Restore?, that has worked 100% of the time. It does not work when editing it.