Todo list automation

Wondering if anyone else is running into this issue or has a solution for this. I have a notification that brings up a todo list on my mobile device when it enters a geolocation. The automation works just fine and has been working…however a while back there was a snafu with todo lists on a home assistant update (about a month or two ago) and this has been an issue for me ever since …when the automation runs; HA throws these errors. I have reviewed the automation many times and i don’t find anything wrong… Is anyone else experiencing this? Or what can i do to fix it? Do i need to raise a git hub issue? …because this seems to be an issue with todo lists in general as i have a few other todo lists that seem to fail/disappear every time i create them.

2024-04-08 15_28_08-Settings – Home Assistant - Vivaldi
2024-04-08 15_31_43-Settings – Home Assistant - Vivaldi

Hi, have you tried to do this service call manually in the development tools?

I have not.
I have 2 steps in the automation, one worked fine, the other seems to throw an error when i test it out in ‘services’.
The first error complains about not finding my phone.

Thinking that this was something to do with the device id’s I switched to the entity id’s instead.

I get a different error after taht, i don’t know what this second error means…

Have you looked at the automation traces?
Also: if you want to send a notification to your phone, it has to be known.
In the Developer Tools → SERVICES: try to call the 'notify.mobile_app_ to see what it does.

This basic test worked without issue…

strangely, there are no traces for any mobile notification that uses a todo list… (I know this automation had just did a ‘production’ run today.

2024-04-08 23_54_03-Settings – Home Assistant - Vivaldi

This is a full yaml of a todo notification

alias: Mobile - Menards Notification
description: >-
  This Automation will send a notification to Andrews Phone and send a menards
  shopping list to both Andrew's and fiance's phone
  - platform: zone
    entity_id: device_tracker.andrew_phone
    zone: zone.menardslocation
    event: enter
condition: []
  - alias: Send TTS message to Andrews Phone
    service: notify.mobile_app_andrewphone
        ttl: 0
        priority: high
        media_stream: alarm_stream
        tts_text: >-
          Hello Andrew and fiance, I noticed you were close to Menards. Tap this
          notification to see your current list of shopping items.
      message: TTS
  - alias: Send Grocery List to Andrew And fiance Phone
    service: script.shopping_list_notification
        - 08fd1000a829fb88a1511f88b6ae8745
        - 4268bf24cf7afbb7e6e5c8061abcf064
      notify_title: Menards Shopping List
      notify_home_or_away: Both
        - 0
        - 143
        - 36
      data_clickaction_url: /andrew-dashboard/menards
      notify_message: Menards Shopping List
      data_notification_icon: mdi:cart
mode: single

Andrew, sorry man but I have no idea what might be wrong.
You could try to break that automation down and/or use alternatives to understand what is really wrong.

Just an idea: if I troubleshoot an automation, I use scripts so you’re not dependent on triggers and conditions.

I think I’m going to go the route of rebuilding my HA instance from scratch in a new VM…really sucks because I’m about 2 years deep into it, but my OS has been really unstable since the past couple of updates…ever since todo lists was introduced HA has basically become unreliable to the point where i will just get disconnect notifications on my desktop…indicating that HA has just died for no reason.
I’ve tried restoring from backups, but that doesn’t help and now with the most recent update, I can’t even do it. Supervisor updates, then refuses to boot and reverts back to 2024.4.1…all that said, thanks for the attempt.

Unless I’m missing something, you’re not sending a todo list but a url to it.
So you’re calling a script and pass on the data?
The trace should either be in the main automation or in the script.

I think you don’t see traces because the script doesn’t run.

About you’re HA instance: your issue could be related, or not.
Maybe by starting over, you get the chance to review your backup strategy…