Token for smartthings integraion

Hi; installed ha on hyper v; running; subscruibed to home assistant cloud;
tryting connect to smartthings;
have the token from smartthings;
howev,er the webhook created by gives a 405 error [method not allowed] and will not work when i add the token; any idea why the webhook generated by casa is having issues?

tried restareting server multiple times but keep getting the same error.

thank ayou

Maybe this is done for you (don’t know much about Nabu Casa) but make sure that your external URL is correct. This is done through Config > Settings > General.

casa nub is the cloud subsciprtion for home assistant; ;there isnot external url spot available for config/settings general; i assume thats because i have the cloud subscription

Just to be sure, did you follow the instructions here exactly?
SmartThings - Home Assistant (

followed exactly

Calling… directly will give you a 405 error. (Mine does and the integration is working.) So just confirm that the smartthings webhook starts with and ends with a long string of hex code.
I can recall having to try this more than once to get it to work. Try deleting the smartthings integration and starting over.