Toon van Eneco custom component


#283

No One ?
It seems that the toonapilib does update to version 3.0.1 but still I have the error message for Toon.


#284

Ik have the same issues, some fixes to the toonapilib where committed, but not released yet.


#285

Are you using the latest version of the custom component?


#286

Ah, ok so the component itself needs also be updated. I thought only the lib.
I’ll give it a try, thanx !


#287

Yes !! It is working again !
I have copied over the new file and directories to the custom_components folder and Toon is working again.
Thank you very much !!


#288

I have an problem to install the ToonAPIlib.

Conf: standard PI3 with hassio and hass 69.1 and a non rooted Toon. I have download and installed the scripts from github for this custom component. After a restart of Hassio i get the error that the toonapilib is missing.

So i want to install the toonapilib, but i dont get it. I have read a lot but i cant find a description step by step how to install this lib.

Have i to download the files? Where do i install them? Where do i have to give the command $ pip install toonapilib?

Can i find somewhere a step by step tutorial?


#289

The lib is updated from the custom component.


#290

Hi

Since yesterday i received the below error in the logs.

I did an update to 0.69.1 ( HassIo ) and after a reboot my Toon configuration was invalid.

Toonapilib 3.0.1
Latest Toon code from github

I have this Toon version a few weeks already and it worked fine so not 100% sure what caused the invalid config

Any ideas what this could be?

Error during setup of component toon
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/setup.py", line 145, in _async_setup_component
    component.setup, hass, processed_config)
  File "/usr/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/config/custom_components/toon.py", line 70, in setup
    config['toon'][CONF_NAME])
  File "/config/custom_components/toon.py", line 108, in __init__
    display_common_name=name)
  File "/config/deps/lib/python3.6/site-packages/toonapilib/toonapilib.py", line 100, in __init__
    self._authenticate()
  File "/config/deps/lib/python3.6/site-packages/toonapilib/toonapilib.py", line 147, in _authenticate
    self._get_agreements()
  File "/config/deps/lib/python3.6/site-packages/toonapilib/toonapilib.py", line 168, in _get_agreements
    for agreement in agreements]
  File "/config/deps/lib/python3.6/site-packages/toonapilib/toonapilib.py", line 168, in <listcomp>
    for agreement in agreements]
AttributeError: 'str' object has no attribute 'get'

Regards
Smikje


#291

Could you please use v3.0.2 that will shed some more light on this issue and report on the library’s issue tracker? there is already an issue tracking this https://github.com/costastf/toonapilib/issues/11. please be careful when pasting output from this version as it might expose personal details.


#292

Are these changes merged into Hass? i would like to get rid of the custom component warnings regarding Toon :slight_smile:


#293

I was working on this a few months ago, but due to personal issues i don’t have access to a Toon unit anymore and probably won’t have for a long time. This is also why i haven’t been on here much lately.

Merging with hass isn’t that hard though, it’s just very time consuming. Assuming that the component is fully working, anyone can start a PR on the main repo.


#294

Hi @boltgolt i am sorry to hear about your personal issues :frowning: I was wondering what happened with the component and this clears that one up. Is anyone interested/willing to pick the task of merging the latest component to the mainline and maintain it? A big thanks to @boltgolt for taking it this far!


#295

really like this as its using the new and supported API. I can read all the values from the Toon. But when I try to change the temperature, nothing happen. With the original Toon component of Home assistant I could change the temperature. But now it seems no changes are going through to the Toon.

update: I tried the toonapilib itself and that does seems to change the the program on my Toon when I send

toon.thermostat_state = 'comfort'

but when I execute

entity_id: climate.toon_van_eneco
operation_mode: performance

in home assistant nothing happens


#296

This sounds like an issue with the component. I have no time sadly but around October I think I will have time to pick the component up an push it through to HA main line if none else has done it already.


#297

I have the same error, love you plugin reading the values works perfect. But not able to change anythig. Can’t figure out why. Anybody else having any luck. thinking about rooting the Toon to exclude Eneco :slight_smile:


#298

I can strongly recommend rooting (or let someone root it for you, is what I did) the Toon!

  • You can then cancel the monthly Toon op Afstand subscription (saves you 54,- euros per year)
  • Have a 100% stable local connection to your Toon. No more signals that don’t reach your Toon.

#299

Thanx already reading the topic : https://ehoco.nl/rooten-van-enecos-toon-thermostaat/ should be possible


#300

Wich Custom Script do you use in Home Assistant for the rooted Toon ?


#301

For a rooted Toon you can use this: https://github.com/cyberjunky/home-assistant-custom-components#toon-thermostat-climate-component


#302

Thanx spend 3 hours yesterday with Toon :slight_smile: it works perfectly now. Toon rooted