Toon van Eneco custom component


#162

I guess not… i do have one of the latest custom component and i know that costas helped me a lot making it work with my setup because the custom component simply wasn’t working in my situation. This was because of a few plugs i have that don’t measure power. After costas help it worked! But it kept trying to retrieve power consumption from the plugs… that’s why i keep getting errors in the log.

Reading an earlier post, i see that costas mentions:


#163

Thanks! Added the custom_components to the HASS folder and it’s working!


#164

Just an idea:

configuration.yaml

toon:
    username: !secret toon_username
    password: !secret toon_password
    exclude:
      entities:
        - sensor.tv_hoek_today_energy

or

toon:
    username: !secret toon_username
    password: !secret toon_password
    allow_smartplug_energy: false

#165

HI All, first of all thanks for all the great work on this custom TOON component!

I have a question, and i am not sure if it’s just me… but my logs are filling up with errors, i read that the API is very unstable, but there are just so many errors.

I am using the custom files from: https://github.com/krocat/ToonHA

Errors:
2017-12-01 13:40:31 WARNING (SyncWorker_15) [toonlib.Toon] Detected a timeout. Re-authenticating and retrying request. 2017-12-01 13:40:32 WARNING (MainThread) [homeassistant.helpers.entity] Update of sensor.gas_current is taking over 10 seconds

This error is repeated for all the TOON sensors.

Thanks!


#166

The quote was more about the naming we used internally, which has been fixed.

I heard there’s a new API that’s actually functional and doesn’t depend on us reverse engineering the app. We’d have to rewrite most of the core library for this but this should fix both of your issues @kurniawan77 @PostSven. I have no clue how quickly this new API can be implemented as i don’t have access to it, but it’s something to look forward for.


#167

Aha, oké understand.
New API would be great but until then, are there a few lines in the custom component that I can uncomment so that there is no switchplug energy reading? Or no switchplug’s at all? I just need the climate part…


#168

I got the burner status working on my Too!

Another feature what would be awsome is see the if there is hot tapwater used.
Toon is visualizing it in his own display but should it be possible to view this is also in Home Assistant?


#169

@kurniawan77 You could remove lines 43 to 54 in /sensor/toon.py to disable the sensor and both 18 and 19 in /switch/toon.py to remove the switch part. Let me know if it works.

@Imperial-Guard Where is you Toon displaying that? I don’t think mine has that functionality at all.


#170

I think it has to do with the OpenTherm functionality.

So when I use hotwater for certain amount of time I see water tap symbol with a flame


#171

Interesting, can you see this in the app too?


#172


#173

This works perfect!


#174

Hi,

I think the physical Toon device sees if it has the burner on for heat. Then it displays the heating symbol. If it does not heat, but the burner is on, it must a water demand.
By the wy, keep up the good work all.

Regards

Bert


#175

Not sure if I can post this here, but I have been using the custom component version of @rdnzl for my rooted Toon for a while now. Until yesterday it worked perfectly.

However, I’ve updated HASS to the latest version (0.59.2) yesterday and now I’m not able to see the climate.toon custom component anymore. The Toon p1-values are still being retrieved, so the interfacing is still working.

Anyone experiencing the same?


#176

Off topic but all climate components needed to be upgraded before 0.59 went live because of an internal change in hass. You can ask the original developer to implement supported_features or implement it yourself.


#177

I have updated the climate/toon.py file in my github repo, had it running with development code for some time, forgot to push it…


#178

thanks a lot!


#179

I tried the updated code but still can’t see the component in Hassio frontend. Did I miss a step?

And does it work on the non-rooted Toon or should I root it? If yes, where to find instruction to root?


#180

There are 2 components for controlling Toon:

  1. for non-rooted Toons, by using your toonopafstand account
  2. for rooted Toons, for which you need to root your Toon. There’s a subforum on domoticaforum.eu with all the information

#181

People with issues with the Toon after the Hass.io update?
Mine is not visible anymore