Total_increasing sensor: how to get rid of first peak on dashboard


I checked all documentation and googled and searched the community, but I could not figure out how to solve it.
I was able to get the power consumption for both electricity and heating onto my energy dashboard. It correctly shows the value on my meter (ok for guess, it is converting to kWh instead of GJ, but I upvoted a feature request to be able to change the units in the dashboard).

But my problem is the high initial peak as you can see on the picture. It looks as if the whole energy consumtion of several years happend on day 1 (of course, because it does not know the history of the meter).
But I am wondering, if there is the possibility to set an initial offset so that the dashboard calculates the delta from the starting point. Of course I could create a template sensor and substract the intial value, but that feels kinda odd…

In the picture you will see an ultra high peak - even the other values are not presented anymore.
I know, the data for tomorrow will look “normal” but the peak will f’up the graph for a day, week or month whenever this peak is included in the data to be presented.

Here is my configuration for the sensor based on MQTT:

  - sensor: 
        name: „Fernwärme Verbrauch GJ"
        state_topic: "tele/tasmota_690D1B/SENSOR"
        json_attributes_topic: "tele/tasmota_690D1B/SENSOR"
        value_template: "{{ value_json.KSMC402.HeatEnergyE1 | float }}"
        unit_of_measurement: 'GJ'
        device_class: energy
        state_class: total_increasing

I think your best bet would be to create a template sensor with an offset (so subtract all your previous usage to get it to 0). Or ignore it and just know that first day’s data is skewed.

You can change the values in Developer Tools > Statistics … in the far right column you will see an indicator if it allows to adjust the sum

Yeah, I was thinking about the same options, but I was hoping there is smarter way…
Thanks anyways.

Strange, it all shows 0 in “Developer Tools > Statistics” for that sensor.

Doublechecking: you browsed through the various timeslots for that day?