Totally confused and lost - Zigbee2MQTT

I purchased a preflashed Zigbee2MQTT USB Dongle CC2531 . I dont really know what I am doing but installed it on Proxmox (not familiar with this but it seemed to work) then went to integrations in Home Assistant and added Zigbee selected my USB reconised dongle then added a Tradfri remote. Excellent? No!
I realised I actually wanted Zigbee2MQTT as that was the guide I watched previously.
I then deleted the Zigbee integration and went on to install from the Add on store the latest (with gui interface) Z2M module, after a little messing with MQTT (I think I put broker name in wrong format) I got it working. All green in logs - I followed instruction (pressed remote button 4x) but cannot get anything!
I then deleted the USB, restart, reinstall, etc all to no avail.
I’ve also tried to go back to the Zigbee (built in) integration and although I can load the USB module I cannot now get it to add the remote.
Spent 5 hours and really frustrated.
Thanks if you can assist.

What hardware do you use ?
Which home Assistant installation method ?
Whare are you trying to achieve ?

You want to use Zigbee2MQTT, good choice from my point of view. You succeeded to install it and got it working with MQTT broker : well done.
So your problem is that you did not succeed to include what ? which remote are you talking about ?
Did you think to activate the “join option” before trying to join anything ? Did you try to put your module close to your CC2531 coordinator to add it ? Did you activate a more verbuose log level and had a look to Z2M logs ?

Hi Thanks for your help.
I have an Intel NUC Running Hassos (i.e not the docker version, the simple version) I believe its simply called “Home Assistant” running all the latest builds.
I am slowly moving away from Smartthings and initially want to include some Zigbee devices into HA directly using the Zigbee2Mqtt method through the add-on store via the repository.
Having done some research this, as you concur, seems to be a favorable route.
As the log has all green lines I assume that the install is correct - I’ve posted my log at the bottom.
If I was sure the install was correct I would persist to try and get the devices discovered but I am anxious it may not be, having already spent five hours on it.
As I say I initially mistakenly installed HA’s integrated Zigbee and it installed and found the device, An Ikea Tradfri remote. Realising my mistake I removed the installation but couldn’t get the Zigbee2Mqtt to discover it. So as a test reinstalled the integrated Zigbee which then wouldn’t find it either despite initially having found it.
Yes I clicked “permit to Join” top right of GUI however it went from grey to grey, though a green box quickly came up, bottom right, saying “Zigbee allowing new devices to join”.
Yes I have also tried to be close up to the coordinator,etc…
Could it be that its been joined and now needs removing, I had deleted it and reset it.
No I haven’t gone down the line of verbose log level as I’m not familiar…
Thanks for help

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] done.
[services.d] starting services
[services.d] done.
./run.sh: line 17: [Info] Configuration backup found in /share/zigbee2mqtt/.configuration.yaml.bk. Skipping config backup.: No such file or directory
[Info] Socat is DISABLED and not started
2020-11-19T14:24:15: PM2 log: Launching in no daemon mode
2020-11-19T14:24:16: PM2 log: App [npm:0] starting in -fork mode-
2020-11-19T14:24:16: PM2 log: App [npm:0] online

[email protected] start /zigbee2mqtt-1.16.1
node index.js
Zigbee2MQTT:info 2020-11-19 14:24:18: Logging to console and directory: ‘/share/zigbee2mqtt/log/2020-11-19.14-24-17’ filename: log.txt
Zigbee2MQTT:info 2020-11-19 14:24:18: Starting Zigbee2MQTT version 1.16.1 (commit #1.16.1)
Zigbee2MQTT:info 2020-11-19 14:24:18: Starting zigbee-herdsman…
Zigbee2MQTT:info 2020-11-19 14:24:21: zigbee-herdsman started
Zigbee2MQTT:info 2020-11-19 14:24:21: Coordinator firmware version: ‘{“meta”:{“maintrel”:3,“majorrel”:2,“minorrel”:6,“product”:0,“revision”:20190608,“transportrev”:2},“type”:“zStack12”}’
Zigbee2MQTT:info 2020-11-19 14:24:21: Currently 0 devices are joined:
Zigbee2MQTT:info 2020-11-19 14:24:21: Zigbee: disabling joining new devices.
Zigbee2MQTT:info 2020-11-19 14:24:21: Started frontend on port 8099
Zigbee2MQTT:info 2020-11-19 14:24:21: Connecting to MQTT server at mqtt://core-mosquitto
Zigbee2MQTT:info 2020-11-19 14:24:21: Connected to MQTT server
Zigbee2MQTT:info 2020-11-19 14:24:21: MQTT publish: topic ‘zigbee2mqtt/bridge/state’, payload ‘online’
Zigbee2MQTT:info 2020-11-19 14:24:21: MQTT publish: topic ‘zigbee2mqtt/bridge/info’, payload ‘{“commit”:“1.16.1”,“config”:{“advanced”:{“adapter_concurrent”:null,“availability_blacklist”:[],“availability_blocklist”:[],“availability_passlist”:[],“availability_timeout”:0,“availability_whitelist”:[],“cache_state”:true,“cache_state_persistent”:true,“cache_state_send_on_startup”:true,“channel”:11,“elapsed”:false,“ext_pan_id”:[221,221,221,221,221,221,221,221],“homeassistant_discovery_topic”:“homeassistant”,“homeassistant_legacy_triggers”:true,“homeassistant_status_topic”:“hass/status”,“last_seen”:“disable”,“legacy_api”:true,“log_directory”:"/share/zigbee2mqtt/log/%TIMESTAMP%",“log_file”:“log.txt”,“log_level”:“info”,“log_output”:[“console”,“file”],“log_rotation”:true,“log_syslog”:{},“pan_id”:6754,“report”:false,“soft_reset_timeout”:0,“timestamp_format”:“YYYY-MM-DD HH:mm:ss”},“ban”:[],“blocklist”:[],“device_options”:{},“devices”:{},“experimental”:{“new_api”:true,“output”:“json”},“external_converters”:[],“frontend”:{“port”:8099},“groups”:{},“homeassistant”:true,“map_options”:{“graphviz”:{“colors”:{“fill”:{“coordinator”:"#e04e5d",“enddevice”:"#fff8ce",“router”:"#4ea3e0"},“font”:{“coordinator”:"#ffffff",“enddevice”:"#000000",“router”:"#ffffff"},“line”:{“active”:"#009900",“inactive”:"#994444"}}}},“mqtt”:{“base_topic”:“zigbee2mqtt”,“include_device_information”:false,“server”:“mqtt://core-mosquitto”,“user”:“MQTTUSER”},“passlist”:[],“permit_join”:false,“queue”:{},“serial”:{“disable_led”:false,“port”:"/dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0014DA3B0A-if00"},“whitelist”:[]},“coordinator”:{“meta”:{“maintrel”:3,“majorrel”:2,“minorrel”:6,“product”:0,“revision”:20190608,“transportrev”:2},“type”:“zStack12”},“log_level”:“info”,“network”:{“channel”:11,“extended_pan_id”:“0x3a3dcbcdbe801457”,“pan_id”:6754},“permit_join”:false,“version”:“1.16.1”}’
Zigbee2MQTT:info 2020-11-19 14:24:21: MQTT publish: topic ‘zigbee2mqtt/bridge/devices’, payload ‘[{“definition”:null,“endpoints”:{“1”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“11”:{“bindings”:[],“clusters”:{“input”:[“ssIasAce”],“output”:[“ssIasZone”,“ssIasWd”]}},“110”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“12”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“13”:{“bindings”:[],“clusters”:{“input”:[“genOta”],“output”:[]}},“2”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“242”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“3”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“4”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“47”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“5”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“6”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}},“8”:{“bindings”:[],“clusters”:{“input”:[],“output”:[]}}},“friendly_name”:“Coordinator”,“ieee_address”:“0x00124b0014da3b0a”,“interview_completed”:true,“interviewing”:false,“network_address”:0,“supported”:false,“type”:“Coordinator”}]’
Zigbee2MQTT:info 2020-11-19 14:24:21: MQTT publish: topic ‘zigbee2mqtt/bridge/groups’, payload ‘[]’
Zigbee2MQTT:info 2020-11-19 14:24:21: MQTT publish: topic ‘zigbee2mqtt/bridge/config’, payload

Which one of the four types listed in the following table are you using?

OS, Supervised, Container, or Core?

My guess is “Core” based on “not the docker version, the simple version” (except that version was never known as “hassos”).

Sorry - “OS” is my installation.
image

It says HassOS

OK, so as you can see from the table, that version does indeed use docker. It also supports Add-ons which explains why you were able to install the Zigbee2MQTT Add-On (which you would not be able to do if you had installed the Container or Core types).

Is it fair to say that everything you have that is ZigBee based is working except for the Tradfri Remote? Or is the problem more widespread?

If it’s only the Tradfri Remote, you may wish to consider installing ControllerX. It’s specially designed to make remote-controls easier to use in Home Assistant.

1 Like

NO - I have only tried the TRadfri remote right now.
I have also just tried this on my phone and have actually managed to get a result which I dont understand. I’ll look a bit deeper and revert shortly.

OK, It eventually worked. For some reason on my phone install. I have no idea. But thanks anyway.